It's all about the answers!

Ask a question

Does RTC 4.0.0.1 Support ClearQuest Importer from ClearQuest 8.0.0.4 Server ?


Fred Bickford (28828) | asked Oct 04 '12, 4:33 p.m.
JAZZ DEVELOPER
Trying to get the ClearQuest Importer to work, yet it crashes in the background(no UI indicaiton to user)

Windows Server runnning 4.0.0.1 with ClearQuest 8.0.0.4 on that machine I have tried Juno SR1 with RTC plugged in(I know that Eclipse is current) yet I have also tried from Win7 remote machine running Eclipse 3.6 and 3.7 (both have been solid for months of other RTC use)

All have used Java 1.6

In reading https://jazz.net/library/article/735, I tried the suggested workaround to no avail

below is a snippet of the stack(I have the full dmp and trc if anyone wants to see them)

!ENTRY org.eclipse.ui 4 0 2012-10-04 16:17:15.581
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NoClassDefFoundError: com.rational.clearquest.cqjni.CQClearQuest (initialization failure)
    at java.lang.J9VMInternals.initialize(J9VMInternals.java:140)
    at com.ibm.rational.connector.cq.setup.internal.CQAdminService.getDbSetNames(CQAdminService.java:130)
    at com.ibm.rational.connector.cq.ide.ui.importer.internal.CQImportMainPage.populateSchemaRepo(CQImportMainPage.java:560)
    at com.ibm.rational.connector.cq.ide.ui.importer.internal.CQImportMainPage.createControl(CQImportMainPage.java:181)


Comments
Fred Bickford commented Oct 05 '12, 10:51 a.m.
JAZZ DEVELOPER

I have now tried to use the native RTC IDE results:

RTC 4.0.0.1 on 7.1.2.x CQ Installed System (appears to work, import dialog thrown) yet the 7.1.2 system cannot access the rmeote schema repo- so this doesnt provide relief

RTC 4.0.0.1 on 8.0.0.4 installed CQ system(server itself) same issue as before, appears to crash sliently to the user.

I guess I should submit this as a defect

3 answers



permanent link
Matthew Alexander (18126) | answered Oct 05 '12, 4:00 p.m.
JAZZ DEVELOPER
Hi Fred,

The ClearQuest importer is supported with RTC 4.0.0.1 and ClearQuest 8.0.0.4.  I've recently used RTC 4.0.0.1 and ClearQuest 8.0.0.3 myself.

Could you confirm that you are using the 32-bit RTC client?  The ClearQuest importer will only work with the 32-bit client due to a ClearQuest limitation.

The ClearQuest importer in RTC needs access to the cqjni.jar file that ClearQuest provides.  It seems that the ClearQuest importer is unable to find it on your machine.  I'm going to paste an answer I gave to a Windows XP user who had problems starting the ClearQuest importer below.  You may want to check these steps as well

- - - - -
Make sure the cqjni.jar file is on the same machine as your RTC client.  It should be, if CQ is installed.  The cqjni.jar file is usually located in the ...IBM\RationalSDLC\ClearQuest directory.

The CQ Import Wizard finds the cqjni.jar file by checking your system's environment variables.  To view environment variables on Windows XP, right-click on the "My Computer" desktop icon and select "Properties", then click the "Advanced" tab.  Next, click the "Environment Variables" button.

The CQ Import Wizard looks for the cqjni.jar variable by first checking the CLASSPATH variable, then the CLEARQUEST_HOME variable, then the RATIONAL_HOME variable, then the CQ_HOME variable.  One of these should contain a listing for the directory that contains your cqjni.jar file.  If they do not, manually add it to one of the variables.  The variables should have been set during the CQ installation.

If you still have problems, you may try adding the full path including the cqjni.jar file to a variable.  For example, the CLASSPATH may be set to include C:\IBM\RationalSDLC\ClearQuest\cqjni.jar

It may take a reboot of your machine to recognize changes to the environment variables.

Good luck, and let me know if you still have problems.

permanent link
Fred Bickford (28828) | answered Oct 07 '12, 11:29 p.m.
JAZZ DEVELOPER
I am using the 64 bit instance on both(win7 and 2008r2), I have tried the other workarounds to no avail, I will try the 32 bit install...yet was this in some doc I missed ?


Should know in a few minutes if the 32bit client works for me..


Thanks

Fred


permanent link
Fred Bickford (28828) | answered Oct 08 '12, 9:19 a.m.
JAZZ DEVELOPER
32 Bit client worked... thanks....

Your answer


Register or to post your answer.