It's all about the answers!

Ask a question

Installing Eclipse Plugin to RTC 4


Jojie Valiente (3021417) | asked Sep 26 '12, 10:20 p.m.

Hi, I would like to know how to install eclipse plugin to RTC 4.

I tried to instal Eclipse Indigo plugin using this site http://download.eclipse.org/releases/indigo but I'm getting error after selecting   "Web, XML, Java EE and OSGi Enterprise Development".  Please see the error below:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Dali Java Persistence Tools - EclipseLink JAXB Support 1.0.2.v201202073020-7741BgJ9EEAREX8z0A9572 (org.eclipse.jpt.jaxb.eclipselink.feature.feature.group 1.0.2.v201202073020-7741BgJ9EEAREX8z0A9572)
  Software being installed: PHP Development Tools (PDT) SDK Feature 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O (org.eclipse.php.sdk.feature.group 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O)
  Software currently installed: Rational Team Concert Client including launchers for standalone installation 4.0.0.RTC-I20120612-0919 (com.ibm.team.concert.uuid 4.0.0.RTC-I20120612-0919)
  Only one of the following can be installed at once:
    Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)
    Core Runtime 3.5.0.v20090525 (org.eclipse.core.runtime 3.5.0.v20090525)
    Core Runtime 3.6.0.v20100505 (org.eclipse.core.runtime 3.6.0.v20100505)
  Only one of the following can be installed at once:
    Equinox Launcher 1.2.0.v20110502 (org.eclipse.equinox.launcher 1.2.0.v20110502)
    Equinox Launcher 1.1.1.R36x_v20101122_1400 (org.eclipse.equinox.launcher 1.1.1.R36x_v20101122_1400)
    Equinox Launcher 1.0.201.R35x_v20090715 (org.eclipse.equinox.launcher 1.0.201.R35x_v20090715)
  Cannot satisfy dependency:
    From: Rational Team Concert Client including launchers for standalone installation 4.0.0.RTC-I20120612-0919 (com.ibm.team.concert.uuid 4.0.0.RTC-I20120612-0919)
    To: org.eclipse.equinox.launcher [1.1.1.R36x_v20101122_1400]
  Cannot satisfy dependency:
    From: Dynamic Languages Toolkit - Core Frameworks 3.0.0.v20101211-0331-7l--ED-z0UkgZToe6HfMg (org.eclipse.dltk.core.feature.group 3.0.0.v20101211-0331-7l--ED-z0UkgZToe6HfMg)
    To: org.eclipse.platform.feature.group 3.4.0
  Cannot satisfy dependency:
    From: Dynamic Languages Toolkit - Core Frameworks 3.0.0.v20101211-0331-7l-2ED-z0UkhYdtV3_LBO (org.eclipse.dltk.core.feature.group 3.0.0.v20101211-0331-7l-2ED-z0UkhYdtV3_LBO)
    To: org.eclipse.platform.feature.group 3.4.0
  Cannot satisfy dependency:
    From: Dynamic Languages Toolkit - Core H2 Index Frameworks 3.0.0.v20101026-0553-79--9oA5885GAJ (org.eclipse.dltk.core.index.feature.group 3.0.0.v20101026-0553-79--9oA5885GAJ)
    To: org.eclipse.dltk.core.feature.group [3.0.0,4.0.0)
  Cannot satisfy dependency:
    From: Dali Java Persistence Tools - EclipseLink JAXB Support 1.0.2.v201202073020-7741BgJ9EEAREX8z0A9572 (org.eclipse.jpt.jaxb.eclipselink.feature.feature.group 1.0.2.v201202073020-7741BgJ9EEAREX8z0A9572)
    To: org.eclipse.jpt.jaxb.eclipselink.ui [1.1.0.v201105110000]
  Cannot satisfy dependency:
    From: Dali Java Persistence Tools - EclipseLink MOXy Support - UI 1.1.0.v201105110000 (org.eclipse.jpt.jaxb.eclipselink.ui 1.1.0.v201105110000)
    To: bundle org.eclipse.core.runtime [3.7.0,4.0.0)
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) Runtime Feature 3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ (org.eclipse.php.feature.group 3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ)
    To: org.eclipse.dltk.core.index.feature.group 3.0.0
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) SDK Feature 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O (org.eclipse.php.sdk.feature.group 3.0.0.v201201110400-77-184_2BEICRgM_fMVcz0M4Va9O)
    To: org.eclipse.php.feature.group [3.0.1.v201201110400-7V-79F8NcJTcJTTTJwJJ]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7 (org.eclipse.platform.feature.group 3.5.1.R35x_v20090910-9gEeG1_FthkNDSP2odXdThaOu9GFDPn83DGB7)
    To: org.eclipse.rcp.feature.group [3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB (org.eclipse.platform.feature.group 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB)
    To: org.eclipse.rcp.feature.group [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
    To: org.eclipse.rcp.feature.group [3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f (org.eclipse.platform.feature.group 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f)
    To: org.eclipse.rcp.feature.group [3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK)
    To: org.eclipse.rcp.feature.group [3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
    To: org.eclipse.rcp.feature.group [3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6 (org.eclipse.rcp.feature.group 3.5.1.R35x_v20090811-9SA0FxVFqE70OL1ARMrfcO6e7BA6)
    To: org.eclipse.equinox.launcher [1.0.201.R35x_v20090715]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6 (org.eclipse.rcp.feature.group 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6)
    To: org.eclipse.equinox.launcher [1.0.201.R35x_v20090715]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY (org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY)
    To: org.eclipse.core.runtime [3.6.0.v20100505]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY (org.eclipse.rcp.feature.group 3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY)
    To: org.eclipse.equinox.launcher [1.2.0.v20110502]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A (org.eclipse.rcp.feature.group 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A)
    To: org.eclipse.equinox.launcher [1.2.0.v20110502]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272 (org.eclipse.rcp.feature.group 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272)
    To: org.eclipse.equinox.launcher [1.2.0.v20110502]

Accepted answer


permanent link
Clement Liu (1.5k54249) | answered Sep 26 '12, 10:58 p.m.
Try this:

Check the "Java EE tools" only

Jojie Valiente selected this answer as the correct answer

Comments
Jojie Valiente commented Sep 26 '12, 11:21 p.m.

It works! It's a bit weird though, because in previous version of RTC 3.0.1.3 and 3.0 iFix1, I just normally select the parent group 'Web, XML, and Java EE Development' and I'm not getting any error.

Anyway, thanks a lot!

One other answer



permanent link
Clement Liu (1.5k54249) | answered Sep 26 '12, 10:34 p.m.
edited Sep 26 '12, 10:37 p.m.
RTC 4 is based on Eclipse v3.6(helios). You should use this repository instead:


But not sure why you want to install an "Eclipse" plugin since again, RTC 4 is based on Eclipse v3.6 and you should be able to do the stuffs that you would do with a pure Eclipse shell. 

Comments
Jojie Valiente commented Sep 26 '12, 10:47 p.m.

That's what my assumption as well, but when I tried to add a new project the 'Java EE' option is not available.

I tried as well your suggestion to use Eclipse v3.6(helios), but it still giving the same error.

Any other suggestion?

My goal is just to create a Java EE type of project using the Eclipse IDE of RTC 4.

Your answer


Register or to post your answer.