It's all about the answers!

Ask a question

RTC cleints - Cannot find package http://open-services.net/xmlns/cm/1.0/


Norman Dignard (356670121) | asked May 02 '17, 1:45 p.m.

We just upgraded to 602 moving from a single server to distributed env. In our new network topology our servers don't have internet connectivity.

Users using the RTC client or CLI for builds are getting an issue in their automated builds and clients querying for a work item "Cannot find package http://open-services.net/xmlns/cm/1.0/:  How to resolve this, if per our security requirements , the servers and/or clients don't have internet access?

Accepted answer


permanent link
Christopher Robinson (571617) | answered May 22 '17, 1:38 p.m.

 The resolution was found for this issue.  The main issue was caused by an invalid header detection on our nginx server.  They modified their configuration to
pass the header onto the CCM server and it resolved the issue.

Norman Dignard selected this answer as the correct answer

Comments
Brett Waldo commented Oct 21 '20, 9:17 a.m.

 OMG @ctrobins   I found this page after a lot of google searching. I'm having the same exact issue (just upgraded to 6.0.2).  Can you please elaborate on the exact nginx changes. I've tried both 


proxy_pass_request_headers      on;
 and
underscores_in_headers on;

Thanks!

2 other answers



permanent link
Donald Nong (14.4k314) | answered May 03 '17, 2:39 a.m.

Many CLM servers are running in isolated environments, and internet access is not a requirement at all. Also, http://open-services.net/xmlns/cm/1.0/ is a namespace, not an actual web site, so it is a bit strange that it is being accessed. If I search the error message, a tool called "Go Build" shows up. Can you confirm it is being used? If so, you may need to look into that direction.


Comments
Norman Dignard commented May 06 '17, 11:02 a.m.

I have no idea on "Go Builds" however the problem can be seen by entering a work item number in the rtc client search box . It returns a popup with the error. If you enter a colon before the number it works eg ":3245".  The RTC command line build scripts also have this problem. 


permanent link
Lawrence Smith (3764) | answered May 10 '17, 10:06 a.m.
JAZZ DEVELOPER

This may be related to the "accessExternalSchema" change that came in with Java.


for a different symptom: Configuring Eclipse with a VM parameter to avoid "unconfigured" project area editors
The defect is: Defect 387309: Project Area Configuration - Empty/Missing information in Mac OS Luna Eclipse Client

The problem occurs when there is a reference in the xml to an external scheme. I the prior case it was for 


<process-specification xmlns="http://com.ibm.team.process">


There is probably a similar line at the header of some xml loaded in the path discussed here.


The fix is to add the VM arg: 

-Djavax.xml.accessExternalSchema=all


to the launcher.  

Your answer


Register or to post your answer.