It's all about the answers!

Ask a question

RTC eclipse client not connecting after enabling TLS v1.2 in WAS


Vidya Jothiraman (3112) | asked Jan 28 '16, 10:37 p.m.
retagged Jan 29 '16, 9:54 a.m. by Patricia Der (5011)
Hi

Since we have a dependency to update the WAS to support TLS v1.2 for compliance, we did the changes as in https://jazz.net/help-dev/clm/index.jsp? re=1&topic=/com.ibm.jazz.install.doc/topics/t_enable_tls1.2_was. html&scope=null

But after this the RTC eclipse client is not connecting to this profile, and gives error as : Remote host closed connection during handshake SSL peer shut down incorrectly

Web client access works fine.

2 answers



permanent link
Rohit Balduwa (945311) | answered Jan 29 '16, 12:54 a.m.
Hi Vidya

You need to configure Rational Team Concert client to support the TLS 1.2 protocol.
Steps:
1. Go to the directory where the Rational Team Concert client is installed. The default location on Windows is Program Files\IBM\TeamConcert and on the UNIX systems is opt/IBM/TeamConcert.
2. Open the eclipse.ini file for editing and add the following protocol:
-Dcom.ibm.team.repository.transport.client.protocol=TLSv1.2
3. Save and close the eclipse.ini file.

Reference article:
http://www-01.ibm.com/support/knowledgecenter/SSYMRC_6.0.1/com.ibm.jazz.install.doc/topics/t_enable_tls1.2_rtc.html?lang=en

If this answers your question please mark it as accepted.

Regards,
Rohit




permanent link
Vidya Jothiraman (3112) | answered Jan 29 '16, 1:51 a.m.
Hi Rohit

Thanks for your answer. Yes we did the same. but found new version of client have got to be used after this TLS v1.2 is enabled. Not sure if this is the requirement. ie I was using 4.0.2 and connecting 4.0.7, got this error.

So installed 4.0.7 and then tried connecting, and now it works.

Is there any pre-requisite like this?

Comments
Rohit Balduwa commented Jan 29 '16, 2:14 a.m.

Hi Vidya

In my scenario, the server was CLM6.0.1.
I did tried connecting the RTC eclipse client 5.0( N-1 level) and 6.0.1(same level) after adding the property to enable TLS1.2 and it works fine.

Limited TLS1.2 support and support for the National Institute of Standards and Technology (NIST) standard SP 800-131A has been added from CLM4.0.4. Please see the New and Noteworthy features:
https://jazz.net/downloads/rational-team-concert/releases/4.0.4?p=news#security-404

In your scenario, your server is CLM4.0.7 and RTC eclipse client is 4.0.2. Hence, CLM4.0.2 will not support TLS1.2 as this feature begins from version 4.0.4.

If this answers your question please mark it as accepted.

Regards,
Rohit

Your answer


Register or to post your answer.