It's all about the answers!

Ask a question

Unable to install RTC 2012 with WAS 8.5


Nicolas Echavarria (34812) | asked Sep 19 '12, 2:48 a.m.
Hello guys!

We are trying to install RTC 2012 v.4.0 in a Windows 2008R2 SP1 DataCenter Server 64-bit
As an App Server we are going for WAS 8.5 Express and for DB, DB2 10.1 Express. For LDAP we'll be using IBM Tivoli DS 6.3

Everything was running right until we started applying the required customizations for WAS.
The instance never came back up.
After reading more, we found that we were using WAS 8.5 Express 32 bit.
After hours of search and downloads we can't seem to obtain an specific installer for WAS 8.5 Express 64 bit.
The only one available is IBM WebSphere Application Server - Express V8.5 for Multiplatform Multilingual eAssembly (CRIM6ML). We tried installing again but no luck -> 32 bits.

Can you point us in the right direction?
Are we using the wrong installer for WAS?

Waiting for your feedback,

Thanks!

Nicolas E.


4 answers



permanent link
T M (8876187143) | answered Sep 19 '12, 4:40 a.m.
Is WAS 8.5 supported? 32-bit WAS supported on a 64-bit OS? Please check the system requirements.

permanent link
Kazuo Fujita (147) | answered Sep 19 '12, 4:51 a.m.
This Answer is not for me and is for Ncolas.

permanent link
Karl Weinert (2.0k52736) | answered Sep 19 '12, 9:01 a.m.
JAZZ DEVELOPER
edited Sep 19 '12, 9:05 a.m.
The supported version of WebSphere is v8.0.0.3 and  the express versions are only available in 32 bit at least that is the case for the 7.0

What are you using for the  initial and max heap sizes?
With a 32 bit WAS you can't go over 2 gigs and will need to set them to 2048 instead of 4096

If this is for production you should be able to download the version that is bundled from passport advantage
If you search PPA for IBM Rational Team Concert V4.0 it should return a list of all the software that is bundled with the product including the supported version of WebSphere.


If it is just for testing you can try changing the heap sizes as above.

Comments
Nicolas Echavarria commented Sep 19 '12, 7:53 p.m.

Karl,

This means that WAS 8.5 Base would not work with RTC? Do we have to go with 8.0.0.3?


Karl Weinert commented Sep 20 '12, 6:51 a.m.
JAZZ DEVELOPER

Nicolas, it means that it hasn't been tested yet. My recommendation would be to use a supported version because if you do run into problems it will be much easier to get help.


Nicolas Echavarria commented Sep 21 '12, 2:31 a.m.

Karl,

Thanks so much! We managed to get RTC 2012 4.0 running on WAS 8.5 with DB2 10.1 and LDAP with ITDS 6.3

Thanks a lot for your help!

Nicolas E.


permanent link
Nicolas Echavarria (34812) | answered Sep 21 '12, 2:32 a.m.
A nice note on the topic of 64 bit installations of WAS in versions 8.0 and 8.5 from IBM Tech Support:
---
Hi Nicolas,
The install bits for WAS v8 and 8.5 are not labled 32-bit or 64-bit 
like in WAS v7. With WAS v8.x if you install the 
"IBM 64-bit SDK for Java, Version 6" then the 64-bit edition of WebSphere Application Server will be installed.
.
Likewise if you install the "IBM 32-bit SDK for Java, Version 6" then the 32-bit edition of WebSphere Application Server will be installed.
.
The below document provides additional detail.
.
Title: WebSphere Application Server V8.0 and V8.5 may offer "Program Files (x86)" as the default installation directory, even when 64-bit components are installed 
http://www-01.ibm.com/support/ docview.wss?uid=swg21608755
.
From the PartnerWorld download site,  for my search text I enter:
Rational Team Concert v4.0 . That contained the below WAS download:
-                                                                         
IBM WebSphere Application Server V8.0 (1 of 4) for Multiplatform        
Multilingual IMPORTANT: All parts of this image (CZM9HML, CZM9IML,      
CZM9JML and CZVG3ML) must be extracted into the same directory to create
a local repository (CZM9HML)                                             
-                                                 
Note it does not mention 32 or 64 bit. The 32 or 64 bit install, will depend on which SDK is select to be install, as mentioned above.
.
.
For Rational Team Concert v4.0 requirments doc, I do not see WAS v8.5 as supported.
.
The below documents show the supported OS's(Non-Clustered & Clustered).
                  -and-
The supported  Application Servers ((Non-Clustered & Clustered)
.
Title: Rational Team Concert System Requirements List                   
http://www-01.ibm.com/support/ docview.wss?uid=swg27015811                
 .                                                                        
->>> the above doc takes you to the below document.                     
 .                                                                        
Title: System Requirements for CLM 2012 including Rational Team Concert 
4.0,...                                                                   
https://jazz.net/library/ article/811                                     
-                                                                         
Server Host Operating Systems (Non-Clustered)                            
*Windows Server 2008 R2 Enterprise Edition x86-64                       
*Windows Server 2008 R2 Standard Edition x86-64                         
*Windows Server 2008 SP2 Enterprise Edition x86-64                      
*Windows Server 2008 SP2 Standard Edition x86-64                        
.                                                                        
Server Host Operating Systems (Clustered) New for CLM 2012              
* No windows OS's                                                        
.                                                                         
Application Servers (Non-Clustered)                                      
*Apache Tomcat 7 [Bundled] New version for CLM 2012                     
*WebSphere Application Server v8.0.0.3 x86-64 [Bundled] New CML 2012    
*Websphere Application Server Network Deployment v8003 new CLM 2012     
*WebSphere Application Server for z/OS v8.0.0.3 New CLM 2012            
*WebSphere Application Server v7.0 Fixpack 23                           
*WebSphere Application Server ND v7.0 Fp 23 New CML 2012                
*WebSphere Application Server OEM Edition for z/OS v7.0 Fixpack 23      
.                                                                         
Application Servers (Clustered) New for CLM 2012                        
.                                                                         
CLM applications can be clustered using the following application       
servers:                                                                  
.                                                                         
*Websphere Application Server Network Deployment v8.0.0.3 New CLM 2012  
*WebSphere Application Server Network Deployment v7.0 FP 23 New CLM 2012 
.

Your answer


Register or to post your answer.