It's all about the answers!

Ask a question

RQMCopyUtility : Unable to copy the project artifacts from one project to another


Rajesh Avanthi (10814120173) | asked Aug 24 '12, 6:32 a.m.
I need to copy from a project called "Quality Manager" on jazz008 to a   project on jazztt2.  I have created a "Quality Manager" project to copy           
into.


NOTE:      jazz008 is at v3.0.1.1 and jazztt2 is at v3.0.1 (All are QM projects)
 
                                                                            
                                                                                  
If I issue the command ...                                                        
                                                                                  
java -jar RQMCopyUtility.jar -s=https://jazz008.hursley.ibm.com:9443/jazz/service/com.ibm.rqm.integration.service.                                
IIntegrationService/resources/Quality+Manager -us=HURJAZZ@uk.ibm.com -pws=xxx -d=https://jazztt2.hursley.ibm.com:9443/qm/service/com.ibm.rqm.           
integration.service.IIntegrationService/resources/Quality+Manager -ud=HURJAZZ@uk.ibm.com -pwd=xxx -l=importlog`date +%s`.html -                      
a=configuration         
                                                          
                                                                                  
... I get an enourmous error message but which finishes with the following satements ...                                                  
                                                                                  
"An error response was received from the Jazz Team Server. Status=400.            
Message: The primary ContributorHandle for the ContributorHandle with the \"[UUID _VpEukOg5EeCIcqyT5jkL8Q]\" item ID could not be looked up."}          
                                                                                  
I checked all databases for VpEukOg5EeCIcqyT5jkL8Q and found it in the CCM and QM databases of the destination instance jazztt2.  There were 39 instances in CCM and 42 instances in QM.                                       
                                                                                  
I tried to clean the databases with ...                                           
                                                                                  
./repotools-ccm.sh -export toFile=ccm.tar -clean                                  
./repotools-qm.sh -export toFile=qm.tar -clean                                    
                                                                                  
./repotools-ccm.sh -import fromFile=ccm.tar                                       
./repotools-qm.sh -import fromFile=qm.tar                                         
                                                                                  
... which reduced the count to 14 instances in CCM and 17 instances in QM but when I issued the RQMCopyUtil command again I got the same  problem.                                                                          
                                                      

Additional Information:
=======================

Added the user as an administrator and a member of the  project with a Test Team Member role but received the same error.
I tried a different user id and had what was basically the same message but this time the ContributorHandle that could not be looked up was _Agn4uOg6EeCIcqyT5jkL8Q.  Does this indicate that what is being looked up is specific to the user?           

The intention is not to copy over everything from one project to the other, but to copy as much of the environment as possible.  We will be using repotools to copy users from one instance to the other but it was hoped that RQMCopyUtil would be able to copy details of their  membership of a project and their roles within the

Any inputs on this would be really helpful.



Thanks in advance

Regards
Rajesh

2 answers



permanent link
Pramod Chandoria (2.1k11220) | answered Aug 24 '12, 2:57 p.m.
JAZZ DEVELOPER
Rajesh
Copy utility is supported for source and target server with same version. Although API's are often compatible but there may be edge cases

permanent link
Rajat Singh (59833442) | answered Aug 30 '12, 5:36 a.m.

Hi Rajesh

Copy utility is not compatible between cross servers.

Also please note that not all the test artifacts are supported by copy utility.

You can get the list of supported resources by firing the -la command (java -jar RQMCopyUtility.jar -la).

If the utility encounters any of the un-supported resources, the copy is interrupted.

Hope this helps!!

Best Regards

Rajat

Your answer


Register or to post your answer.