It's all about the answers!

Ask a question

iRAM Server Setup Error : ERROR CRRAM803I: Security - CRRAM3021E


Novi Styarif (111) | asked Jun 22 '12, 3:37 a.m.

Hello,

I’m trying to install IBM Rational Asset Manager v7.5.1; I use the server setup installation to install rational asset manager in my existing WebSphere Application Server. For database I use DB2 v9.7, when I deploy the application I didn’t get the problem, it was successfully deployed, but when I go to step 2 (Configuration Database) I get error like this:

1)       “ERROR CRRAM803I: Security - CRRAM3021E - The server setup application cannot verify that the user wasadmin is a repository administrator. For more information, see the Rational Asset Manager help system”

2)       ERROR CRRAM901E: RAM - Cannot verify RAM Configuration, database connection is null.

3)       ERROR CRRAM803I: Security - CRRAM3021E - The server setup application cannot verify that the user wasadmin is a repository administrator. For more information, see the Rational Asset Manager help system.

4)       ERROR CRRAM701E: Database - Error - Performance DatabaseSettings readDatabaseSettings failed because connection was null

Could somebody give me the instruction to solve this problem?

Thanks in advance,

Novi Styarif W


Comments
Jorge Iglesias commented Feb 25 '13, 5:48 a.m.

Hi Novi,

Have you solved the error? How?

Thanks, Jorge

5 answers



permanent link
Rich Kulp (3.6k38) | answered Jun 22 '12, 9:53 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
edited Jun 22 '12, 9:55 a.m.
Did you turn on both "Enable administrative security"and "Enable application security" in WAS? (See Security->Global Security in the WAS Console). Without those both being turned on Server setup cannot determine if the logged in user is a WAS admin or not. The user who logs in Server Setup needs to be a WAS admin.

Note: By default application security is turned off.

permanent link
Novi Styarif (111) | answered Jun 24 '12, 10:46 p.m.

Hi Richard,

Yes I have turn on both "Enable administrative security"and "Enable application security" in WAS, but still problem. Actually I used user “wasadmin” to login Server Setup and WAS also, not “admin”. Could this be caused I used user “wasadmin”, if yes, how to set the user “wasadmin” to “admin”?


permanent link
Rich Kulp (3.6k38) | answered Jun 25 '12, 9:43 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
No, as long as wasadmin is a WAS admin then that is ok.

Next need to verify the user role mapping is correct. From WAS Console click the EnterpriseApplications->com.ibm.ram.repository.setup.web.ear->Security Rolw to user/group mapping and verify that "Administrator" is mapped to "All Authenticated in Application's Realm" and "Everyone" is mapped to "everyone".

permanent link
Novi Styarif (111) | answered Jun 26 '12, 6:46 a.m.

Hi Richard,

Actually the security role to user/group was configure ( "Administrator" is mapped to "All Authenticated in Application's Realm" and "Everyone" is mapped to "everyone"), but the problem still same. When I click the "Administrator" and then I click "Map Users", I get some user like "samples, wasadmin, and admin". Could this user must be selected?


permanent link
Rajasimhan Mandayam (381134) | answered Jun 26 '12, 1:07 p.m.
JAZZ DEVELOPER
1. login to was admin console
2. click on security
3. click on your current security type (possibly federated) find out who the primary admin user is.
4. login to server setup as that user, click on deployment>previous, choose security type as the type above, click next.... go through setup.

Your answer


Register or to post your answer.