It's all about the answers!

Ask a question

How to solve Error: Unable to create attribute type "com.ibm.team.interop_RESERVED_FOR_INTEROP"


0
1
Harmen Leenders (324) | asked Jun 12 '12, 6:12 a.m.

Dear reader,

I am trying to import a multistream project from Clearcase using the import function (no history from clearcase) and ran into the following error (partly copied logging below). Does anybody has experience with this error? Does anybody know how to get this solved and what the root cause can be?

Kind regards,

Harmen Leenders

cleartool

: Warning: Trigger "no_mkattype" has refused to let mktype proceed.

Interactive triggers are not supported in the Web interface.

If the trigger was interactive, it may have failed for that reason.

cleartool

: Error: Unable to create attribute type "com.ibm.team.interop_RESERVED_FOR_INTEROP".

Accepted answer


permanent link
Geoffrey Clemm (30.1k23035) | answered Jun 12 '12, 7:48 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Apparently, your admin has installed in your VOB has a custom trigger named "no_mkattype" that prevents a client from creating an attribute type in that VOB.  The synchronizer needs to be able to create attribute types.

You need to either disable that custom trigger, or modify it so that the synchronizer is allowed.  For details, see:

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/index.jsp?topic=%2Fcom.ibm.team.connector.scm.cc.doc%2Ftopics%2Ft_sync_cc_triggers.html

To find this topic, you could have typed "clearcase trigger" in the on-line help search window.

Harmen Leenders selected this answer as the correct answer

Comments
Harmen Leenders commented Jun 19 '12, 4:43 a.m.

Well, putting 'import all history' checkbox to TRUE solved the problem partly (workaround).

Nevertheless, I was not able to create the attribute yet by the manual actions too (second answer). Probably as this answer suggests some trigger is preventing me for creating the attribute.

Thanks for the answer!

One other answer



permanent link
Ralph Schoon (61.4k33643) | answered Jun 12 '12, 6:31 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Harmen,

I have seen similar things happening in the past. The importer uses cleartool. The log should show the command it tries to run. Please open a shell on the machine you run the import and try to run the cleartool commands in that shell.

I ran into a case, where we tried to use the synchronizer and the permissions or settings on that machine were wrong. Cleartool failed,....

If you can run the commands, maybe your trigger really failed and that is the reason. I am unfortunately no experienced cleartool user, so I can't hint more.

Your answer


Register or to post your answer.