It's all about the answers!

Ask a question

Trouble upgrading RTC 3.0 to iFix1


Erich Wolz (162177) | asked Jun 03 '11, 1:03 p.m.
I installed RTC v3 some time ago, but didn't do anything further with that particular installation because the CMVC connector I also wanted to use at the time required RTC v2. Well, now there is a new project starting up that wants to use RTC, that does not have a requirement for the CMVC connector, so I naturally thought that a good a starting point as any would be to upgrade my RTC v3 installation to iFix1.

I made it to the Jazz Team Server and Application Setup window (/jts/setup#/steps/10) which informed me, "Congratulations, you have successfully completed the setup." Clicking Finish took me to the /jts/admin page; I was able to click on the Home|Server|Users|Reports tabs and see pretty much what I expect to see.

However, when I went to the /ccm/admin page, the Status Summary told me, "This application needs to be registered with a Jazz Team Server to function correctly. To proceed, use the Setup Wizard located on the Jazz Team Server (For example: https://servername.domain.com:9443/jts/setup)." This, even though I just did use the Setup Wizard and got a "Congratulations" message.

My JazzTeamServer/server/conf/ccm/teamserver.properties seem to look OK (as in: as near as I can tell they now look the same as they did before starting the iFix1 upgrade), but ccm does not think it's connected to a Jazz Team Server. I even tried going to the /ccm/setup page and going through the configuration steps for the CCM application (even though these steps were already done as part of the /jts/setup). When I got to /ccm/setup#/steps/3 I was told, "Finalization is not required or has already been completed for this application. Please click 'Next' to continue" but the 'Next' button was never enabled.

Any ideas as to what/where I should be checking?

3 answers



permanent link
Ralph Schoon (56.0k23642) | answered Jun 07 '11, 3:29 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Erich,

please be aware that when going to 3.0 the upgrade scenario gets a bit complex, especially if you want to later run several RTC instances with a common licensing. Especially where you deploy the JTS server is important for later migrations from RTC 2.x

You can look into the help under development here:
http://cclbld39.beaverton.ibm.com:9081/CLM2011help/topic/com.ibm.jazz.install.doc/topics/c_upgrade_overview.html

or

http://cclbld40.beaverton.ibm.com:9081/CLM2011help/topic/com.ibm.jazz.install.doc/topics/c_upgrade_overview.html


Other than that you could have a look into the server admin pages https://<server>:<port>/jts/admin and https://<server>:<port>/ccm/admin

For JTS, can you run diagnostics? For both check the consumers and friends entries in the communications section. You could also check the logs (sever/logs at tomcat, logs in the profile for WAS).

I think the application registering during migration did fail but I am not sure why and how to recover. You might want to create a work item.

Thanks,

Ralph

I installed RTC v3 some time ago, but didn't do anything further with that particular installation because the CMVC connector I also wanted to use at the time required RTC v2. Well, now there is a new project starting up that wants to use RTC, that does not have a requirement for the CMVC connector, so I naturally thought that a good a starting point as any would be to upgrade my RTC v3 installation to iFix1.

I made it to the Jazz Team Server and Application Setup window (/jts/setup#/steps/10) which informed me, "Congratulations, you have successfully completed the setup." Clicking Finish took me to the /jts/admin page; I was able to click on the Home|Server|Users|Reports tabs and see pretty much what I expect to see.

However, when I went to the /ccm/admin page, the Status Summary told me, "This application needs to be registered with a Jazz Team Server to function correctly. To proceed, use the Setup Wizard located on the Jazz Team Server (For example: https://servername.domain.com:9443/jts/setup)." This, even though I just did use the Setup Wizard and got a "Congratulations" message.

My JazzTeamServer/server/conf/ccm/teamserver.properties seem to look OK (as in: as near as I can tell they now look the same as they did before starting the iFix1 upgrade), but ccm does not think it's connected to a Jazz Team Server. I even tried going to the /ccm/setup page and going through the configuration steps for the CCM application (even though these steps were already done as part of the /jts/setup). When I got to /ccm/setup#/steps/3 I was told, "Finalization is not required or has already been completed for this application. Please click 'Next' to continue" but the 'Next' button was never enabled.

Any ideas as to what/where I should be checking?

permanent link
John Vasta (2.6k15) | answered Jun 07 '11, 10:05 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Can you check your server/conf/ccm/teamserver.properties file to see if it contains a setting for the property "com.ibm.team.repository.server.jts.url"? It should be set to your JTS URL. The behavior you describe makes it seem that there is no such property set, but it should have been set by going through the setup wizard.

I installed RTC v3 some time ago, but didn't do anything further with that particular installation because the CMVC connector I also wanted to use at the time required RTC v2. Well, now there is a new project starting up that wants to use RTC, that does not have a requirement for the CMVC connector, so I naturally thought that a good a starting point as any would be to upgrade my RTC v3 installation to iFix1.

I made it to the Jazz Team Server and Application Setup window (/jts/setup#/steps/10) which informed me, "Congratulations, you have successfully completed the setup." Clicking Finish took me to the /jts/admin page; I was able to click on the Home|Server|Users|Reports tabs and see pretty much what I expect to see.

However, when I went to the /ccm/admin page, the Status Summary told me, "This application needs to be registered with a Jazz Team Server to function correctly. To proceed, use the Setup Wizard located on the Jazz Team Server (For example: https://servername.domain.com:9443/jts/setup)." This, even though I just did use the Setup Wizard and got a "Congratulations" message.

My JazzTeamServer/server/conf/ccm/teamserver.properties seem to look OK (as in: as near as I can tell they now look the same as they did before starting the iFix1 upgrade), but ccm does not think it's connected to a Jazz Team Server. I even tried going to the /ccm/setup page and going through the configuration steps for the CCM application (even though these steps were already done as part of the /jts/setup). When I got to /ccm/setup#/steps/3 I was told, "Finalization is not required or has already been completed for this application. Please click 'Next' to continue" but the 'Next' button was never enabled.

Any ideas as to what/where I should be checking?

permanent link
Erich Wolz (162177) | answered Jun 07 '11, 5:43 p.m.
Can you check your server/conf/ccm/teamserver.properties file to see if it contains a setting for the property "com.ibm.team.repository.server.jts.url"? It should be set to your JTS URL. The behavior you describe makes it seem that there is no such property set, but it should have been set by going through the setup wizard.


That was it, thanks!

My server/conf/ccm/teamserver.properties file did not even have the
com.ibm.team.repository.server.jts.url property specified (though it did have the
com.ibm.team.repository.server.webapp.url property specified as the CCM URL).

Your answer


Register or to post your answer.