It's all about the answers!

Ask a question

RTC 2.0.x and Visual Studio 2010


Brent Benton (2643) | asked Nov 23 '10, 5:47 p.m.
http://jazz.net/library/article/544
This page says RTC 2.0.x supports VS 2010.

http://www-01.ibm.com/support/docview.wss?rs=3488&uid=swg27015716
This page has "Unsupported" in the comment in the VS 2010 row.


http://jazz.net/blog/index.php/2010/05/05/rational-team-concert-introduces-support-for-microsoft-visual-studio-2010/
This page says compatibility was achieved in iFix 3 M1

http://search400.bitpipe.com/detail/RES/1281989385_849.html
This page says compatibility was achieved in iFix 4 M1

We downloaded the VS plugin from Jazz.net on August 24th, as well as the Full package - the full package is clearly iFix3, but the VS zip is not clearly marked. An attempt to install it on a machine with only Visual Studio 2010 installed hit an error though, stating that VS 2005 or 2008 was required.

Today I downloaded the VS plugin again, and the filename was slightly different.

Was: RTC-ExpressC-VS-Client-2.0-Win32-Local.zip
Now: RTC-ExpressC-VS-Client-2.0.0.2-Win32-Local.zip

The result was the same however - the installer gets to the prerequisite check stage and reports this error:
"This product requires Microsoft Visual Studio 2005 or Microsoft Visual Studio 2008 to be installed on the system. Please install either of these products and try again."

So... is 2010 supported? If so, please provide a download link and an install order. Thanks.

3 answers



permanent link
Prabodh Mairh (3812) | answered Nov 25 '10, 10:13 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
http://jazz.net/library/article/544
This page says RTC 2.0.x supports VS 2010.

http://www-01.ibm.com/support/docview.wss?rs=3488&uid=swg27015716
This page has "Unsupported" in the comment in the VS 2010 row.


http://jazz.net/blog/index.php/2010/05/05/rational-team-concert-introduces-support-for-microsoft-visual-studio-2010/
This page says compatibility was achieved in iFix 3 M1

http://search400.bitpipe.com/detail/RES/1281989385_849.html
This page says compatibility was achieved in iFix 4 M1

We downloaded the VS plugin from Jazz.net on August 24th, as well as the Full package - the full package is clearly iFix3, but the VS zip is not clearly marked. An attempt to install it on a machine with only Visual Studio 2010 installed hit an error though, stating that VS 2005 or 2008 was required.

Today I downloaded the VS plugin again, and the filename was slightly different.

Was: RTC-ExpressC-VS-Client-2.0-Win32-Local.zip
Now: RTC-ExpressC-VS-Client-2.0.0.2-Win32-Local.zip

The result was the same however - the installer gets to the prerequisite check stage and reports this error:
"This product requires Microsoft Visual Studio 2005 or Microsoft Visual Studio 2008 to be installed on the system. Please install either of these products and try again."

So... is 2010 supported? If so, please provide a download link and an install order. Thanks.


Hi,
We have support for visual studio 2010, it was added in the maintenance release 2.0.0.2 iFix 3, released on 4th June 2010.
You can download it from following location:
https://jazz.net/downloads/rational-team-concert/

You can download 2.0.0.2 iFix 3 or higher (2.0.0.2 iFix4 and iFix5) from this page for visual studio 2010 support. We also released 3.0 version of RTC recently. We would recommend you to try with 3.0 if possible, this will provide you a host of new features as well.

permanent link
Brent Benton (2643) | answered Nov 26 '10, 3:05 p.m.
I somehow had managed to download the original 2.0.0.2 release rather than the latest iFix one. I tried again and this time got

RTC-ExpressC-VS-Client-2.0.0.2iFix5-Win32-Local.zip

rather than

RTC-ExpressC-VS-Client-2.0.0.2-Win32-Local.zip

Thanks for your time.

permanent link
Doug Brown (16) | answered Sep 11 '12, 11:21 a.m.
I just downloaded RTC-VS-Client-2.0.0.2iFix8-Win32-Local.zip and when I run launchpad.exe the I get the same error as above.

the installer gets to the prerequisite check stage and reports this error:
"This product requires Microsoft Visual Studio 2005 or Microsoft Visual Studio 2008 to be installed on the system. Please install either of these products and try again."

So did iFix3, 4 and 5 support VS 2010 and iFix8 does not?

Your answer


Register or to post your answer.