It's all about the answers!

Ask a question

Problem synchronizing RAM 7.2.0.2 with WSRR 7.0


Alberto Conrado (111) | asked Jun 10 '10, 11:38 a.m.
Hi!

We've been trying to synchronize a fresh installation of RAM 7.2.0.2 with our pre-production environment WSRR 7.0, in what we have read constitutes the WSRR ALE product.

We have run into multiple problems, must of which we have been able to solve successfully, but the most important one remains. After installing and configuring a fresh RAM, we follow the steps for the synchronization, including the interchange of certificates in the TrustStore of both WAS and the loading of the SOA library in the RAM interface.

The problem occurs after creating a new community for the sync, and after creating the WSRR connection. When creating the connection, in the web form provided by RAM, we test the connection with the "Test Connection" button and RAM indicates that the connection has been successful. Both RAM and WSRR SystemOut.log logs display messages about the success. After hitting the "OK" button in the web form, we get back to the "Connections" screen. Here, when we use the link "Synchronize Classification", we get the very mysterious message at the top of the page "The server is not valid". At the WSRR SystemOut log we get no message, and at the RAM SystemOut log we get the following message:

[06/07/10 9:38:41:768 CDT] 00000056 SystemOut     O [06/07/10 09:38:41 CDT] CRRAM0001E  4246446 ERROR web pagecode.admin.group.Connections      - The server is not vaild."


We have checked every one of our steps at least three times, including going as far as reinstalling the OS. The same error was showed to us when we first used the eWAS included with RAM 7.2, but we moved to a standalone 7.0.0.7 WAS in order to do the synchronizing.
Right now, the specs for the two virtual machines running RAM and WSRR are:

OS: SLES 10 SP 2
Memory: 3 GB
WAS version: 7.0.0.7 ND
Database used: Oracle 11g release 1 (running in another VM)

We would appreciate any pointers as to what we may be doing wrong, or about what does the "server is not valid" message actually means, as we have not been able to found any documentation surrounding this error, beyond the minimal info included in the InfoCenter which tells us nothing.

Thank you very much

5 answers



permanent link
Alberto Conrado (111) | answered Jun 14 '10, 12:28 p.m.
First of all, sorry for the double post, but I need to add some information about what we have being doing lately, hoping someone can help us to give some light into this problem.

After the failure connecting WSRR 7.0 with RAM 7.2.0.2, we moved into a fresh installation of RAM 7.1.1.1 on a WAS 6.1.0.21. The installation went smooth, with only a known issue encountered and fixed.

Once again, after following the steps for the sync, and after getting "Connection was successful" messages when testing the connection, we finally ended up with the same "The server is not valid" message when trying to synchronize.

The specs for the VM's running each program are the same as the last try, except that this time around the RAM version was 7.1.1.1 and the WAS version was 6.1.0.21.

We would greatly appreciate ANY comment anyone may have about their experience synchronizing RAM and WSRR in any version, as we really haven't found any information regarding this error.
Has anyone synchronized WSRR and RAM? and if you have, which were the specifications of the machines that were synchronized?

Again, thank you very much.

permanent link
Gili Mendel (1.8k56) | answered Jun 16 '10, 12:14 p.m.
JAZZ DEVELOPER
The error in the logs notes that the URL for WSRR is invalid (not set).

Are you sure that after you clicked the test connection button, you saved the connection (using the OK button on the right bottom corner)?

permanent link
Alberto Conrado (111) | answered Jun 16 '10, 1:23 p.m.
Thanks for your answer.

We are pretty sure we hit the "Ok" button after the connection testing. We return to the Connections screen, where we found a new WSRR Connection. It is interesting to note, that the values of the name and the description of the connection do not appear, corresponding with your assertion that the values are not set. We get the connection icon, and the link to synchronize but no name or description.

After my second post, we tried several options and we found the database to be the culprit. We installed DB2 9.7, and we finally were able to synchronize WSRR and RAM. The name and description of the connection appeared when using DB2, and we have been able to manually synchronize, as well as the timed sync.

We are not exactly sure of where is the problem. Either a badly constructed SQL statement in RAM, a bad OJDBC driver (which ironically we used to populate the jazz DBs), or an error in Oracle side. We were not able to locate any errors regarding failed transactions, neither in RAM nor in Oracle.

We are willing to provide any logs and information that the dev team may need in order to reproduce and eventually solve the problem.

As we do not have enough time to solve ourselves or wait for the solution to the problem, we are not pursuing the deployment with Oracle any further, and are settling with DB2, at least for RAM.
Thank you, for you attention and support.

permanent link
Saurabh Agarwal (111123) | answered Jun 17 '10, 12:13 p.m.
JAZZ DEVELOPER
I have opened a defect to trace the issue with Oracle 11g.

https://jazz.net/jazz02/resource/itemName/com.ibm.team.workitem.WorkItem/34359

We will investigate into it.

permanent link
Saurabh Agarwal (111123) | answered Aug 04 '10, 10:56 a.m.
JAZZ DEVELOPER
We tried to reproduce the same, with the similar configuration and everything worked fine. I am resolving the defect for now, please reopen it if you still see this as an issue.

Your answer


Register or to post your answer.