It's all about the answers!

Ask a question

Asset Manager WebServices client


Nikhil Gupta (262) | asked Jul 29 '10, 11:47 a.m.
This is regarding Asset Manager V7.1.1.1 with test fix 13.
I noticed that the POST request RAMAssetAccess.jsp, using the Webservices client, for updating an Asset uses "chunked" "transfer encoding".


We have a WebSEAL reverse Proxy sitting in from of our RAM and the WebSEAL proxy does not support a "chunked" Transfer-Encoding from a client. This essentially causes the request to fail.

My question is, is there a way to not set the "Transfer-Encoding" for such "POST" requests on the client side. Is there a method that can be used to turn off the Transfer-Encoding. I did not see
RAMSession.setChunkedTransfer(false);

Can this be possibly be added to the webservices client api.

3 answers



permanent link
Kevin Bauer (34621) | answered Jul 29 '10, 6:14 p.m.
JAZZ DEVELOPER
We do not have a way to turn off chunked encoding from the asset upload API.

This was required to support large file uploads and we did not add a way to disable it.

permanent link
Nikhil Gupta (262) | answered Jul 30 '10, 2:47 p.m.
Can this be added to the apis. I think it may be a good thing to provide this option.

permanent link
Kevin Bauer (34621) | answered Jul 30 '10, 4:46 p.m.
JAZZ DEVELOPER
You can open an enhancement request at...

http://jazz.net/jazz02/web/projects/Rational%20Asset%20Manager#action=com.ibm.team.workitem.viewWelcome

However, it will not be available for a 7.1.x server.

Your answer


Register or to post your answer.