It's all about the answers!

Ask a question

Rhapsody REST API Web Server does not return the content of Model Elements in Rhapsody using RPE Template

Prashanth Manohar Gopi (158) | asked Jan 11 '21, 1:49 a.m.
edited Jan 11 '21, 1:55 a.m.

 HI All,

I am using Rhapsody 8.4 and RPE 6.0.6, when i tried to generate report using RPE template in IBM Rhapsody, getting an error 

document not generated.

When i tried to paste the Rest API server URL in web browser getting following error:

HTTP ERROR 500 Problem accessing /Rational/Rhapsody/. Reason: com/telelogic/rhapsody/core/RhapsodyAppServer.getActiveRhapsodyApplication()Lcom/telelogic/rhapsody/core/IRPApplication; Caused by: java.lang.UnsatisfiedLinkError: com/telelogic/rhapsody/core/RhapsodyAppServer.getActiveRhapsodyApplication()Lcom/telelogic/rhapsody/core/IRPApplication; at$ServletProcess.callRhapsodyApplication(Unknown Source) at$ServletProcess.doProcess_Synchronized(Unknown Source) at$ServletProcess.doProcess(Unknown Source) at Source) at javax.servlet.http.HttpServlet.service( at javax.servlet.http.HttpServlet.service( at org.mortbay.jetty.servlet.ServletHolder.handle( at org.mortbay.jetty.servlet.ServletHandler.handle( at org.mortbay.jetty.servlet.SessionHandler.handle( at org.mortbay.jetty.handler.ContextHandler.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.Server.handle( at org.mortbay.jetty.HttpConnection.handleRequest( at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete( at org.mortbay.jetty.HttpParser.parseNext( at org.mortbay.jetty.HttpParser.parseAvailable( at org.mortbay.jetty.HttpConnection.handle( at$ at org.mortbay.thread.QueuedThreadPool$

Kindly help me to resolve this error

Fariz Saracevic commented Jan 13 '21, 2:46 a.m.

 I suggest to contact IBM Support to help you with your issue. 

Accepted answer

permanent link
Subramanya Prasad Pilar (4.6k16) | answered Jan 14 '21, 1:01 a.m.

Since you are not getting the XML from Rapsody REST API, this is not RPE issue. Similar issue was reported by another user, where port used by Rhapsody was being blocked by antivirus/firewall. Please check if that is the case.

Prashanth Manohar Gopi selected this answer as the correct answer

Prashanth Manohar Gopi commented Jan 18 '21, 2:09 a.m.

It worked, the problem was due to antivirus  

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.