It's all about the answers!

Ask a question

CCM/RTC build records are not accessible from RQM after build provider setup


Nadine Magusinzky (153) | asked Oct 29 '19, 3:58 a.m.
We enabled CCM/RTC as build provider for RQM following the related help guidelines. Build definitions from CCM showed up in RQM, with question mark icon indicating that build status is unknown, but from the hundreds of existing RTC build records that show up under CCM none are visible in RQM.

Manually creating build records in RQM works as expected. JRS LQE queries find all build records in CCM, but none in RQM.

CLM Setup:
  • CCM 6.0.6.1 RTC-SERVER-I20190326-1811 iFix003
  • RQM 6.0.6.1 I20190326_2031 iFix003
The CCM and RQM applications are hosted on the same server.

In the build provider configuration screen connection to RTC server test passes with green/OK result.

What could have we missed in the configurations?

Is there a known defect / limitation in the CLM application versions we have related to this topic? Based on latest release notes from RQM 6.0.6.1 I found no related issues.

Thank you in advance for your kind support.

Best regards,
 Nad

Comments
Nadine Magusinzky commented Oct 30 '19, 2:24 p.m.
Hello Ian,

 thanks for the very useful hint about the user. It was functional, but it turned out that it lacked a QM license token of some sort. After granting the user that QM license token all the builds appeared as they should.

Thanks once more, problem is solved.

Accepted answer


permanent link
Ian Wark (79713550) | answered Oct 30 '19, 4:15 a.m.
I tried setting up the CCM/QM integration using the JKE Banking sample projects in 6.0.6.1 iFix002 and it seems to obtain both the build definitions and the build records from CCM. I have both project areas hosted on the same server.

Build records

I used these steps:

Did you set up the functional user in step 2? How did you configure that? Did you create a new user? (I didn't need to set up a friend relationship, which was already present.)
Nadine Magusinzky selected this answer as the correct answer

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.