Unable to "Use another repository" when creating a repository workspace.
I am trying to copy components from one Jazz Team Server (“jts_old”) to another one (“jts_new”).
“jts_old” is a v6.0.2 jazz team server and “jts_new” is v6.0.6.
“jts_old” and “jts_new” are both on the same network and use the same Active Directory for user authentication.
“stream1_oldserver” has a few components.
“stream1_newserver” hasn’t got any components yet.
I also have a workstation on the network with an Eclipse client v602 with connections to both “jts_old” and “jts_new”.
‘myuser’ is a Jazz Admin (defined in Active Directory)
‘myuser’ is using RTC Developer Tokens (defined in both “jts_old” and “jts_new”).
‘myuser’ has a role that has the permissions for all of the Source Control settings including “Replicate change sets” and “Save Components”.
Following info from a link I was given in an earlier thread my plan is
-
Use the Eclipse client with connections to both jazz team servers.
-
Create a repository workspace of “stream1_oldserver” and during the creation pick the option to “Use another repository” = ‘myuser@jts_new’
But I get an error when I try to save this repository workspace
Problem occurred running creating ‘myuser duplicate of stream1_oldserver workspace’.
Error invoking remote service at https://old_server:9443/ccm/
javax.net.ssl.SSLHandshakeException : Received fatal alert: handshake failure
Any help will be gratefully received.
Is there a log file I should be looking at ?
Thanks Peter
The article I read was this one
https://jazz.net/library-content/wp-content/uploads/2014/03/RTC_SCMDistributedShippingPoT.pdf
2 answers
- Incompatible cipher suites in use by the client and the server. This would require the client to use (or enable) a cipher suite that is supported by the server.
- Incompatible versions of SSL in use (the server might accept only TLS v1, while the client is capable of only using SSL v3). Again, the client might have to ensure that it uses a compatible version of the SSL/TLS protocol.
- Incomplete trust path for the server certificate; the server's certificate is probably not trusted by the client. This would usually result in a more verbose error, but it is quite possible. Usually the fix is to import the server's CA certificate into the client's trust store.
- The cerificate is issued for a different domain. Again, this would have resulted in a more verbose message, but I'll state the fix here in case this is the cause. The resolution in this case would be get the server (it does not appear to be yours) to use the correct certificate.
Comments
I have heard one report that a user who have had trouble replicating a stream on one server to a stream on another server had better luck replicating a stream on one server to a workspace on another server. That would be worth a try, because it might at least give you a different/better error message.
Comments
Ralph Schoon
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER Nov 16 '18, 5:59 a.m.