It's all about the answers!

Ask a question

Developing custom scripts to automate tasks in DNG (or RTC)


Sean F (1.2k12339) | asked Apr 03 '18, 10:40 a.m.

Is this still the best option for learning how to automate DNG?
https://jazz.net/library/article/635
which reverences the resources at
https://jazz.net/wiki/bin/view/Main/OSLCWorkshopDownload
I want to do things like create/modify artifacts/links etc. (basically what DXL does in old DOORS)

I have followed the setup instructions in the workshop manual 2013-05-15-oslc-workshop.pdf

The eclipse client configuration on page 7 is failing with an error:-

Cannot complete the install because of a conflicting dependency.
  Software being installed: JavaServer Faces Tools (JSF) Project 3.2.3.v201101112207-7E7I7BF9JgLWPMz0VyDEHH (org.eclipse.jsf.feature.feature.group 3.2.3.v201101112207-7E7I7BF9JgLWPMz0VyDEHH)
  Software currently installed: IBM Rational Team Concert Client 2018.4.4.021054 (IBM Rational Team Concert Client com.ibm.sdp.eclipse.ide 2018.4.4.021054)
  Only one of the following can be installed at once:
    Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58)
    Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x)
    Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
    Java Development Tools Core 3.8.4.v20150217-1606 (org.eclipse.jdt.core 3.8.4.v20150217-1606)
  Cannot satisfy dependency:
    From: IBM Rational Team Concert Client 2018.4.4.021054 (IBM Rational Team Concert Client com.ibm.sdp.eclipse.ide 2018.4.4.021054)
    To: org.eclipse.jdt.R422patch.feature.group [1.0.10]
  Cannot satisfy dependency:
    From: IBM Rational Team Concert Client 2018.4.4.021054 (IBM Rational Team Concert Client com.ibm.sdp.eclipse.ide 2018.4.4.021054)
    To: org.eclipse.jdt.feature.group [3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83]
  Cannot satisfy dependency:
    From: JavaServer Faces Tools (JSF) Project 3.2.3.v201101112207-7E7I7BF9JgLWPMz0VyDEHH (org.eclipse.jsf.feature.feature.group 3.2.3.v201101112207-7E7I7BF9JgLWPMz0VyDEHH)
    To: org.eclipse.jst.jsf.common [1.2.2.v201101211220]
  Cannot satisfy dependency:
    From: JavaServer Faces Tools - Common 1.2.2.v201101211220 (org.eclipse.jst.jsf.common 1.2.2.v201101211220)
    To: bundle org.eclipse.jst.jsp.core [1.1.0,1.3.0)
  Cannot satisfy dependency:
    From: Structured Source JSP Model 1.2.300.v201005271731 (org.eclipse.jst.jsp.core 1.2.300.v201005271731)
    To: bundle org.eclipse.jdt.core [3.5.0,3.7.0)
  Cannot satisfy dependency:
    From: Structured Source JSP Model 1.2.302.v201008251735 (org.eclipse.jst.jsp.core 1.2.302.v201008251735)
    To: bundle org.eclipse.jdt.core [3.5.0,3.7.0)
  Cannot satisfy dependency:
    From: Structured Source JSP Model 1.2.304.v201102160550 (org.eclipse.jst.jsp.core 1.2.304.v201102160550)
    To: bundle org.eclipse.jdt.core [3.5.0,3.7.0)
  Cannot satisfy dependency:
    From Patch: org.eclipse.jdt.R422patch.feature.group 1.0.10 Eclipse Java Development Tools 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83 (org.eclipse.jdt.feature.group 3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83)
    To: org.eclipse.jdt.core [3.8.4.v20150217-1606]


Anybody have any idea what to do to resolve this or similar error?


Be the first one to answer this question!


Register or to post your answer.