It's all about the answers!

Ask a question

DNG, JRS, and DCC


Mahari Hill (484177193) | asked Dec 20 '17, 7:36 a.m.

CLM 603

We had a RM DB that we reported artifacts on in JRS. Our client asked if we could rename the OOTB Stakeholder Requirement to HighLevel Requirement. I checked with some admins and a IBM tech rep and was told this would be fine. So, I did a rename in the Manage Project Properties and was able to do a bunch of queries and such and everything worked fine.

The next day we tested a JRS report and ran a report on all HighLevel Requirements and got zero results. We ran a report on all Stakeholder Requirements and got all 80 results. We let DCC run again and got the same result. Only when we created a brand new HighLevelRequirement and moved over everything to this artifact type, did it work.

Is this a defect?

One answer



permanent link
Kenji Sarai (96029) | answered Dec 20 '17, 9:17 p.m.

Hi Mahari,

So do you mean the JRS report created before the rename does not work anymore? I think the artifact type name is hard-coded in this old JRS report. Verify the SQL query in Advanced tab to see if old name "Stakeholder Requirement" is hard-coded in the SQL query.

Your answer


Register or to post your answer.