It's all about the answers!

Ask a question

how to enable Enable Process Attachment Scripts in my trial version ?


Deepak soora (157) | asked Apr 07 '17, 7:34 a.m.

 Enable Process Attachment Scripts needs to be set to true, but i am on my trial version and i dont know how to go to advance settings as an admin.


is it even possible ? so that i can work on creating custom conditions using Dojo scripts ?

i have my web URL to login but is it the same as host name ?

:9443/ccm/admin not working

Accepted answer


permanent link
Ralph Schoon (61.4k33643) | answered Apr 07 '17, 7:50 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Apr 07 '17, 7:58 a.m.

 If 

  • You have administrative access to the CCM server (JazzAdmin repository role)
  • You have write access to the ccm's teamserver.properties file
you can enable attachment scripts.

Easiest way: open Advanced properties using https://myserver:9443/ccm/admin#action=com.ibm.team.repository.admin.configureAdvanced - replace myserver:9442 with your hostname and port. 


On the page search com.ibm.team.workitem.service.internal.WorkItemRepositoryService or Attachment scripts


 set this to true and save.

Or you add 

com.ibm.team.workitem.process.scripts.enabled=true

to the teamserver.properties file

Ralph Schoon selected this answer as the correct answer

Comments
Deepak soora commented Apr 07 '17, 8:02 a.m. | edited Apr 07 '17, 8:02 a.m.

Thankyou soo much for the quick reply.

I got the steps.

But how do I find the port number ? Is the server name same as the web URL we use to login to CCM


Ralph Schoon commented Apr 07 '17, 8:05 a.m. | edited Apr 07 '17, 8:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
 Yes, it is the same port number you use to login to the CCM 

However, you likely neither have JazzAdmin access, nor access to the teamserver.properties on Jazz.net/sandbox01-ccm 

You would have to download RTC and do a local install to try this out.



Deepak soora commented Apr 07 '17, 11:52 p.m.

 I went through the workshops documents, but i don't see a way to enable the JavaScript.


i think i dont have permission - is there anyway at all to enable javascript in my trial version ?

i have RTC 6.0.3 installed and configured in my local desktop as well.

Your answer


Register or to post your answer.