It's all about the answers!

Ask a question

Getting an error when attempting to upload a PDF file to RDNG as a requirements asset


Ken Murphy (1032932) | asked Feb 20 '17, 4:21 p.m.

We have 5.0.2 of the Rational CLM tools.  I am using IE11 and attempting to upload a PDF to RDNG and am getting the following error.  This has worked previously, but not attempted in the last month or so.  I tried this with FF 51.0.1 and am seeing an error (_be.getElementsByTagNameNS is not a function) there, too.  Any ideas?

The file could not be uploaded to the server.
hide details
ID CRRRW7230E  The server request to upload the file to the server could not be completed.
Unable to get property 'getResourceURI' of undefined or null reference
TypeError: Unable to get property 'getResourceURI' of undefined or null reference at com.ibm.rdm.web.server.client.utils.WrapperResourceUtil.processUploadResponse (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:77689:1) at _processUploadResponse (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:82008:1) at Anonymous function (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:81918:1) at Anonymous function (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:450:1) at load (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:81947:1) at Anonymous function (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:6426:1) at _14 (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:2901:1) at _12 (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:2883:1) at callback (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:2927:1) at _14 (https://rassett:9444/rm/web/_js/?include=A~&etag=GyAK3PfhMIt_en_US&_proxyURL=%2Frm&ss=KI36n&locale=en-us:2910:1)


Comments
Donald Nong commented Feb 20 '17, 6:22 p.m.

Some similar cases were reported in the past without confirmed solutions, such as the below two.
https://jazz.net/forum/questions/176432/error-while-uploading-artifiact-imagein-doors-ng-502
https://jazz.net/forum/questions/213551/error-uploading-artifact-in-rational-doors-next-generation-502

I suggest you contact Support and get it investigated further.


Bas Bekker commented Feb 21 '17, 5:58 p.m.
JAZZ DEVELOPER

And as Donald says, best to get in contact with IBM support.

Otherwise, any chance you can trace the request from the web UI to the RM server with Firebug for Firefox or the Chrome developer tools?

Be the first one to answer this question!


Register or to post your answer.