It's all about the answers!

Ask a question

RTC 6.0.3 Build Engine Won't Start - AIX


Chris Rowan (1133) | asked Feb 16 '17, 11:17 a.m.

 I recently upgraded from RTC 5 to 6, including the build engine. I used the AIX zip folder to install. I installed in the same directory as the RTC 5 build engine (after moving the RTC 5 contents). I'm using the same JDK and same command line options. 


It seems to me like either I'm missing something or the something fundamental with the install is broken, as it seems that the build engine won't start because it can't find any of its dependent plugins:

!SESSION 2017-02-16 09:07:24.821 -----------------------------------------------
eclipse.buildId=unknown
java.fullversion=JRE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460sr10-20111207_96808 (JIT enabled, AOT enabled)
J9VM - 20111207_096808
JIT  - r9_20111107_21307ifx1
GC   - 20110519_AA
BootLoader constants: OS=aix, ARCH=ppc64, WS=motif, NL=en_US
Framework arguments:  -repository https://jtcservice-staging.ottawa.ibm.com:9850/ccm/ -engineId drv_jtcservice_staging1 -sleepTime 10 -repositories /home/j9app/swamp/scm_config/repositories
.txt
Command-line arguments:  -repository https://jtcservice-staging.ottawa.ibm.com:9850/ccm/ -engineId drv_jtcservice_staging1 -sleepTime 10 -repositories /home/j9app/swamp/scm_config/repositor
ies.txt

!ENTRY org.eclipse.osgi 2 0 2017-02-16 09:07:26.347
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-02-16 09:07:26.347
!MESSAGE Bundle update@plugins/org.eclipse.equinox.launcher.motif.aix.ppc_1.0.201.R35x_v20091211/ was not resolved.
!SUBENTRY 2 org.eclipse.equinox.launcher.motif.aix.ppc 2 0 2017-02-16 09:07:26.347
!MESSAGE Missing host org.eclipse.equinox.launcher_[1.0.0,1.1.0).

... followed by a list of dozens more dependencies.

It looks to me like the appropriate jar files are all there in the buildengine's plugins directory. Could this be a classpath issue of some kind?

Thanks,
Chris

4 answers



permanent link
Donald Nong (14.3k210) | answered Feb 16 '17, 10:18 p.m.
edited Feb 16 '17, 10:19 p.m.

It can be a launcher issue. Try to navigate to the location where jbe.sh is, and execute it from there. Comparing the jbe.sh file from both 5.0.2 and 6.0.3, the below line is missing from 6.0.3. I am not sure why the change.

cd $BUILD_ECLIPSE

Of course you can also try to add this line back and see if it makes any difference.


Comments
Chris Rowan commented Feb 17 '17, 8:36 a.m.

Thanks for the suggestion, but I did notice that too and tried a number of things, none of which worked:

 - launch from the .../jazz/buildsystem/buildengine/eclipse directory
 - change jbe.sh to hard code the value of BUILD_ECLIPSE to point to the above directory
 - added a classpath option to the java command line: -cp .../jazz/buildsystem/buildengine/eclipse/plugins

I get the same error regardless.

Chris


Donald Nong commented Feb 19 '17, 8:25 p.m.

I think it's time to get in touch with Support.


permanent link
Ralph Schoon (54.4k13641) | answered Feb 17 '17, 9:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Feb 17 '17, 9:23 a.m.

 I don't know AIX that well, but I have had trouble with the JBE. That was related to the Java version and architecture. I summarized it here: https://rsjazz.wordpress.com/2015/04/07/the-day-the-jbe-stood-still/


I noticed that with 6.0.3 the JBE is available in 32 and 64 bit. At least in the plain zip file section you can choose what you download for some of the operating systems. I am not sure if there might be a change for AIX though, as there is only one download. 

Wild guess, but might be worth checking which Java version you run on.


permanent link
Chris Rowan (1133) | answered Feb 17 '17, 9:38 a.m.

 For what it's worth, as an experiment I downloaded the linux version of the build engine. Installed on a linux server and it started without any issues.


permanent link
Chris Rowan (1133) | answered Feb 24 '17, 2:43 p.m.

 I downloaded and installed the 6.0.0 AIX build engine, and it is working fine. I believe there's a problem with the 6.0.3 AIX package.

Your answer


Register or to post your answer.