It's all about the answers!

Ask a question

Export JRS report to RPE : Description field content & Analysis result for workitem not exported to RPE


Jyotsna Prasad (1712) | asked Dec 02 '16, 12:54 a.m.
edited Dec 02 '16, 12:57 a.m.
I have developed a JRS report on Problem Workitem and exported to RPE. JRS report created for Problem WorkItem contains "Description" & "Analysis Result" data but when exported to RPE, the RPE report doesn't display data for "Description" & "Analysis Result".
Can anyone please suggest a way how to retrieve these fields or is there any change in the database as with 6.0.1 , it was working fine. After upgrade to 6.0.2, we are facing this problem.

Kindly guide.

Thank you.




Comments
Tejashree Gupta commented Dec 02 '16, 1:04 a.m. | edited Dec 25 '16, 4:17 p.m.

 Hi Jyotsna,


Could you please take a look at the XMl contents that are being returned from JRS. Please check if it is returning Description & Analysis result data.

Regards
Tejashree


Jyotsna Prasad commented Dec 02 '16, 1:27 a.m.

Hi Tejashree,

Yes I have looked at XML content...it contains description and analysis result field as "rtc_merged_Problem1_description" & "rtc_merged_Problem1_analysisresult".

Regards
Jyotsna


Tejashree Gupta commented Dec 02 '16, 2:26 a.m. | edited Dec 25 '16, 4:18 p.m.

 Hi Jyotsna,


Please can you check if the same fields / attributes ("rtc_merged_Problem1_description" & "rtc_merged_Problem1_analysisresult". )  are used in RPE template. Since you see the values in XML, you should find it in RPE output


Regards
Tejashree


Jyotsna Prasad commented Dec 02 '16, 2:47 a.m.

Hi Tejashree,

I have checked in RPE template. Its present there as results/result/rtc_merged_Problem1_analysisresult but this query is fetching no data. The content is empty there and same for description field. Rest all the fields have data except these two. They are html data. Is there any issue with html in JRS exporting ?

Regards
Jyotsna


Tejashree Gupta commented Dec 02 '16, 5:34 a.m.

 When you say 'they are html data'. Do you mean it is in XHTML format ?


Regards
Tejashree


Jyotsna Prasad commented Dec 02 '16, 7:38 a.m.

Hi Tejashree,

Yes I think they are stored in XTHML format as previously when we extracted these data , they were being displayed in XHTML format.

Regards
Jyotsna



Tejashree Gupta commented Dec 04 '16, 11:35 p.m.

 Hi Jyotsna,


Can you please confirm it again ? Since that might have changed and could be causing this issue.

Regards
Tejashree


Jyotsna Prasad commented Dec 05 '16, 4:08 a.m.

Hi Tejashree,

These are large html data.

Regards
Jyotsna


Tejashree Gupta commented Dec 06 '16, 12:49 a.m.

 Hi Jyotsna,


Can you compare the xml from 6.0.1 & 6.0.2 ? We suspect that the data returned from 6.0.2 is lacking some information in the XHTML fields.

Regards
Tejashree

showing 5 of 9 show 4 more comments

Be the first one to answer this question!


Register or to post your answer.