It's all about the answers!

Ask a question

[RTC6.0.1] Plan view widget displays error instead of progress bar


Olivier Béghain (1081933) | asked Jan 16 '16, 3:07 p.m.
Hello,

I've a RTC 6.0.1 server running (no RQM nor RDNG, just RTC).

In a "SCRUM" based project area, I've several "Sprint Backlog" plans. In each of these "Sprint Backlog" plans, I've a custom view that:
- restrict the list of work items so that it only displays the WIs assigned to a particular user
- groups WIs based on the owner
- exclude empty groups
- show the progress bar

When showing the plan (not through the widget), no problems; I only get the WIs assigned to a particular user and see the progress bar (specific to that user).

Now, when I present that same plan through a widget on the user's dashboard (using the "Plan View" dashboard), instead of seeing the progress bar, I see "Error" (have a look at attached screenshot). I get this error indepedently the dashboard is maximized or not.



This is problematic since I'm looking for a solution to present on personal dashboard (for each project team member) the remaining capacity and personal progress and therefore hoped to use the progress/load bars. If you have suggestions using other widgets or means, they are welcome. If you can help me to resolve this problem, even better!

Web browsers used: Safari, Firefox,


Regards,
Olivier




Comments
Olivier Béghain commented Jan 16 '16, 10:45 p.m.

Btw. The problem is also applicable when the selected "plan view" is the default "Planned Time" that comes with the Sprint Backlog plan type. 


Robert Carter commented Mar 25 '16, 9:04 a.m.

I am also getting this error with a 6.0.1 environment. 


Don Yang commented Mar 30 '16, 12:41 a.m.
  1. Do you have ''Fetch Children On Demand' on in your plan view? if yes, how about removing it and see if it helps?
  2. check jts.log and ccm.log at the time (see ERROR) and see more info is there.
  3. potentially this is related to the known defect in v6.0.1:
    Group by Team in plans with deferred load of plan elements and progress breaks progress bars for groups and shows error in plan view.



Robert Carter commented Mar 30 '16, 11:04 a.m.
  1. Unchecked 'Fetch Children on Demand'.  Error still occurs on dashboard.
    1. Nothing in the error logs of jts and ccm. 
  2. Can test yet as this has not been released.

Robert Carter commented Mar 30 '16, 11:11 a.m. | edited Mar 30 '16, 11:35 a.m.

If I use the Web Inspector and look for errors on the page, I see the following messages:

TypeError: Cannot read property 'getPlanMode' of null
PlanAttributeRegistry: com.ibm.team.apt.plancheck.traditionalSchedulingCheck.attribute may be broken because of dependency on com.ibm.team.apt.attribute.planitem.constraintDate

PlanAttributeRegistry: com.ibm.team.apt.plancheck.traditionalSchedulingCheck.attribute may be broken because of dependency on com.ibm.team.apt.attribute.planitem.constraintType

PlanAttributeRegistry: com.ibm.team.apt.attribute.calm.filter.failingTestCases may be broken because of dependency on planning/source/com.ibm.team.workitem.linktype.testedByTestCase


Don Yang commented Mar 31 '16, 6:57 p.m.

It looks like this is different issue as the known defect. Have you tried different browser?
TypeError could be related to browser specific problem.


Robert Carter commented Mar 31 '16, 8:32 p.m.

Same error message with Browser,

Safari 9.1
Chrome 49.0.2623
Firefox 38.7.0 


Robert Carter commented May 09 '16, 10:07 a.m. | edited May 09 '16, 10:08 a.m.

 I have upgraded to 6.0.2 and this issue is resolved.

showing 5 of 8 show 3 more comments

Be the first one to answer this question!


Register or to post your answer.