It's all about the answers!

Ask a question

Feed url to download all the test scripts with steps for a particular test case

libin sebastian (1746) | asked Sep 11 '15, 9:35 a.m.
edited Sep 12 '15, 10:34 a.m.
 I am using the below feed url to retrieve all the test scripts with steps of a particular test case using test case id using RQm urlutility


With the above command i am able to get the test script name but not the test steps.Can some help me to modify the feed url?

Accepted answer

permanent link
Subramanya Prasad Pilar (4.6k16) | answered Sep 12 '15, 7:17 a.m.
edited Sep 12 '15, 7:23 a.m.
Did you get the same error for original url you posted? You may try using |* after testcase.
It is working as expected for me with RQM 5.0.x.
https://server:port/qm/service/[@href='https://server:port /qm/service/   Management%29/testcase/']|*/steps/step/(name|title))
libin sebastian selected this answer as the correct answer

libin sebastian commented Sep 12 '15, 8:33 a.m. | edited Sep 12 '15, 8:52 a.m.

 I did not get the same error in the original url.I get the error when i use '|' in feed url. How did u post the command?I was using rqm url utility. i have changed the url as u suggested but i still get the same error.

URL used - 
java -jar RQMUrlUtility.jar -command GET -user myid -password mypassword -filepath C:\Users\libin\Desktop\RQMxmls\testscript.xml -url https://localhost:9443/qm/service/[@href='https://localhost:9443//qm/service/']|/steps/step/(name|title))

libin sebastian commented Sep 12 '15, 8:42 a.m. | edited Sep 12 '15, 8:43 a.m.

Snapshot of my command prompt,

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\libin>cd /d F:\Softwares\Testing\RQM-Extras-RQMUrlUtil-6.0

F:\Softwares\Testing\RQM-Extras-RQMUrlUtil-6.0>java -jar RQMUrlUtility.jar -comm
and GET -user myuser -password mypaswd -filepath C:\\Users\\libin\Desktop\\RQ
Mxmls\\testscript.xml -url https://localhost:9443/qm/service/
'*' is not recognized as an internal or external command,
operable program or batch file.


2 other answers

permanent link
Subramanya Prasad Pilar (4.6k16) | answered Sep 11 '15, 2:05 p.m.
edited Sep 11 '15, 2:08 p.m.
You should be using

Please try

Hope this works for you.

libin sebastian commented Sep 11 '15, 10:33 p.m.

It's throwing error  'testcase[@href' is not recognized as an internal or external command.I believe it's not recognizing '*|' given in the url

permanent link
libin sebastian (1746) | answered Sep 12 '15, 11:46 p.m.
edited Sep 12 '15, 11:50 p.m.
 I found the root cause of the issue.If you are running the command from CMD window then url should be enclosed in "".Command to be used in url utility - 

java -jar RQMUrlUtility.jar -command GET -user myid -password mypaswd -filepath <file path> -url "https://localhost:9443/qm/service/<project>/testscript?fields=feed/entry/content/testscript/(testcase[@href='https://localhost:9443/qm/service/<project>/testcase/']|*/steps/step/(name|title))"

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.