It's all about the answers!

Ask a question

Configuring Step By Step OSLC Links with RQM and ClearQuest but Defect form didn't appear


Daniel Torres (749) | asked Jul 02 '15, 5:42 p.m.
Hi, i've been configuring OSLC Links for RQM and ClearQuest using as guides the IBM Knowledge Center for "Rational Collaborative Lifecycle Management Solution 5.0.2" and "Rational ClearQuest 8.0.0", a technote from IBM Support Portal "How to configure ClearQuest Web for Collaborative Lifecycle Management integrations", and also watching some videos like "Configure OSLC integration between ClearQuest V8.0 and Rational Team Concert V4.0" and "Configuring the OSLC-based Rational Team Concert Bridge Integration". 

Scenario:
  • RQM 5.0.2 (have all CLM on 5.0.2 version using sql server 2012 as database and WAS 8.5.5.0)
  • ClearQuest 7.1.2 (using OSLC Links version 1.0 and ms access database)
So i didn't have trouble with get success doing each step of the configuration:
  1. Applying OSLCLinks Package to Defect Record Type (I use version 1.0 because i have clearquest 7.1.2)
  2. Checking the changes of the schema.
  3. Upgrade the user database.
  4. Setup cross-server communication between RQM and ClearQuest Web.
    • Adding as a Friend the ClearQuest Web root services on the RQM admin page.
    • Authorizing the provitional key (OAuth Consumer) on ClearQuest Web.
    • Adding as a Friend the RQM root services on the ClearQuest Web Server Friends List.
    • Authorizing the provitional key on RQM.
  5. Establishing collaboration relationship between a RQM project area and ClearQuest user database.
    • Adding project relationship on ClearQuest Web by selecting RQM Server and the Service Providers (projects).
    • Adding the association on RQM project area by selecting ClearQuest Web Server and using Record Type Defect.
  6. Setup cross-server communication between  JTS and ClearQuest Web.
    • Adding as a Friend the ClearQuest Web root services on the JTS admin page.
    • Authorizing the provitional key (OAuth Consumer) on ClearQuest Web.
    • Adding as a Friend the JTS root services on the ClearQuest Web Server Friends List.
    • Authorizing the provitional key on JTS.
I guess there were all the steps that i have to execute, but when i tried to create a Defect on RQM by going to Change Request and selecting Defect (selecting record type Defect from the schema that i applied the OSLC Links package), it appear a pop-up that only says "Charging..." but never ends to charge the form, so i don't know what else i have to do. Did i did something wrong?

Please i need some help as soon as possible. Thanks.

Accepted answer


permanent link
Alexandre Stegani (8664) | answered Jul 02 '15, 6:21 p.m.
Hi Daniel,

I have seen similar behavior before, and the issue was related to mixed content. Can you please double check if both applications are running as HTTPS? In case ClearQuest is HTTP, and RQM is HTTPS you may see the behavior you are describing.

Here's a technote that may be useful.

http://www-01.ibm.com/support/docview.wss?uid=swg21586892
Daniel Torres selected this answer as the correct answer

Comments
Daniel Torres commented Jul 02 '15, 7:20 p.m.

Thanks Alexandre, thats exactly my case, RQM use HTTPS and ClearQuest use HTTP. On the technote says that the solution is that both (consumer and provider) must use the same connection, so both are HTTP or both are HTTPS, but don't say how to change it. I'll prefer to change HTTPS to ClearQuest ... any finally tip on how to do it? (i'm new on clearquest).


Thanks again.


Daniel Torres commented Jul 02 '15, 8:41 p.m.

 Nevermind, i got the correct port for HTTPS that was already configured.


Thanks a lot!!!

One other answer



permanent link
Daniel Torres (749) | answered Jul 06 '15, 4:25 p.m.
Hi again, I'm not sure if i should create a new question flow or is fine to keep posting my issues here.
Anyway, I can create now a Defect from an RQM project area by going to Change Request, but when i try to create a Defect from the execution of a test case, it open a ClearQuest defect form, but when I try to save it, this message comes: "RequestError: Unable to load /qm/proxy?uri=https%3A%2F%2Fsrv1papra1%3A12443%2Fcqweb%2Foslc%2Frepo%2F7.0.0%2Fdb%2FSAMPL%2Frecord%2F16777224-33554501%3Foslc.properties%3Doslc_cm%253AaffectsTestResult%252Coslc_cm%253ArelatedTestCase%252Coslc_cm%253ArelatedTestPlan status: 400". So the Defect could be created, but without the right link to the test case record.

Also, when i tried to create a defect on ClearQuest and then try to link it to some test artifact like a test case, the form never comes and instead appear this message "No inline editor presentation has been defined for this type of work item. Contact your project administrator."

So, again ... Am I missing something?

Your answer


Register or to post your answer.