It's all about the answers!

Ask a question

Adding Field in Plan View displays '--' instead of value


Richard Herrin (212813) | asked May 08 '15, 11:55 a.m.
 I have a custom field that uses and enumeration of three values.  I have added this field in the Attribute Mapping, but when I add it in the View Mode, it displays '--' instead of the value.  If I open the work item, it has a value.  Why won't the value display in the Plan?

One answer



permanent link
Don Yang (7.6k2196132) | answered May 10 '15, 9:57 p.m.
I tried with v5.0.2 and do see the right value in a custom enumeration attribute adding to plan view. What version of RTC do you use? In which view and template type(Formal process or Scrum) do you see the -- instead of value after adding the custom enumeration attribute to the plan view?

Comments
Richard Herrin commented May 12 '15, 12:00 p.m.

 We are using RTC 5.0.2.  We have a custom template that was used to instantiate our process - it is an Agile template.  We have customized this project area extensively.  


In the plan view, when editing the View Mode, if I add the CreatedBy field, I see the name of the person who created the work item.  However, for this particular field (which is based on an enumeration with three values: Low, Medium, and High), the Plan View Mode shows the -- instead of the value.  If I open the work item, the value appears normally (i.e. Low, Medium, or High).  


Don Yang commented May 12 '15, 11:02 p.m.

Check if the default template based project area has the similar problem or not. In my test, there is no problem to show enumeration values in plan view. If it works for you, we know something is related to the custom project area and it could be hard to tell what is causing that unless the template can be shared. In that case, I guess you may want to contact client support with the custom template for best effort of support.

Your answer


Register or to post your answer.