It's all about the answers!

Ask a question

Firefox not displaying DWA Rich Hovers


Ben Sharples (56838) | asked Apr 24 '15, 6:36 a.m.
edited Apr 28 '15, 8:35 a.m. by Krzysztof Ka┼║mierczyk (7.3k34391)
Hi,

I normally use Firefox for RTC/RQM, etc, however one minor problem I have is that where I have links to a DOORS 9.5 object, the DWA rich hover only displays the first part of the object text.

In internet explorer I get the full DWA rich hover.

The only other difference is in IE I tend to get a show secure content box at the bottom of the screen first time, which when i click then reloads the page and the rich hovers work.
In Firefox I don't get this.

Accepted answer


permanent link
Maeve OReilly (3813) | answered Apr 29 '15, 11:13 a.m.
 Is it possible RTC/RQM are on ssl (https) and DWA is on http?   Firefox might just be blocking non-https content from being shown in a https context.  Modern browsers don't like 'mixed content'. Go to  about:config in the address bar. Locate the parameter security.mixed_content.block_active_content and set it to false.  If that 'fixes' it (by making your whole browser unsecure!), the real solution is to move DWA to https.  From DWA 9.6, there is by default a listen on https://host:8443/dwa.  But for that to work properly, the dbadmin -dwaPort and -dwaProtocol parameters need to be reset and the DWA rootservices in RQM/RTC changed.  
Ben Sharples selected this answer as the correct answer

One other answer



permanent link
Lawrence Smith (3764) | answered Apr 24 '15, 7:22 a.m.
JAZZ DEVELOPER
Try opening a tab in Firefox and log in to Doors there so the authentication is already done. Then try the hover over the link. Check your browser settings to see if pop-up's are blocked on the page.  Also Firefox recently disabled some SSL protocols so perhaps the pop-ups are being blocked by this.

Comments
Ben Sharples commented Apr 29 '15, 7:53 a.m.

Having DOORS running in a different tab doesn't make a difference.

All I get is the first part of the object text, and then a loading circle in the middle of the rich hover (where normally the DWA rich hover appears on IE)

I've not got pop-ups blocked

Your answer


Register or to post your answer.