It's all about the answers!

Ask a question

How to run a really "silent" Jazz RTC setup?


Romuald Tisserand (748) | asked Dec 08 '14, 9:12 a.m.
edited Dec 08 '14, 9:15 a.m.
Hi,
I'm trying to automate a Jazz RTC setup for some development purpose. I've gone in the documentation and read what's provided for a silent RTC installation:
  • Gathering the necessary files
  • Running the setup

But, here, I still don't have any working Jazz RTC, because I didn't run the chapter "Configuring the server - Running the setup from the command line". And what I read here is all but silent because I've to manually answer about 10 questions (DB type, DB location, etc).

Si, I've some additionnal questions:

  • Is there a way to install Jazz RTC with NO human interaction, from nothing to a fully working https://<my-server>:9443/jts server?
  • If yes, where's the documentation about such a procedure?

Thanks. 

OS: Linux

2 answers



permanent link
Donald Nong (14.4k314) | answered Dec 08 '14, 7:25 p.m.
Based on the document, when you run the "repotools-jts -setup" command, you can use the "parametersFile" parameter which points to a file containing the answer to those steps.
http://www-01.ibm.com/support/knowledgecenter/SSYMRC_5.0.1/com.ibm.jazz.install.doc/topics/r_repotools_setup.html

Comments
Romuald Tisserand commented Dec 09 '14, 4:55 a.m.

Thanks Donald. I saw this documentation. The problem is the parameters listed here don't match the questions asked by the RTC setup.

Examples: DB type, DB vendor, users registry, etc


Francois-xavier Panaget commented Dec 09 '14, 5:18 a.m.

Hi Romuald,

The best is to run once the repotools -setup with the "responseFile" parameter.
This will record to a file the answers you specify for the DB Type, Vendor etc...
Once you have finished, the "reponsefile" properties file will be written to disk.
This file can afterwards should be used to with the "parametersFile" parameter to run the setup silently.

I hope this will help you.
Regards,
Francois


Romuald Tisserand commented Dec 15 '14, 9:15 a.m. | edited Dec 15 '14, 6:29 p.m.

Hi,
First of all, I want to thank Fran├žois-Xavier Panaget for his useful tip. Then, I want to apologize for my silence, but I took a long time to run several testing.

As I said, I'm trying to automate JTS 5.0.1 deployment on a Vagrant Ubuntu Server box. And I think, I've reached a reproductible procedure...which doesn't work.

My Vagrant box is provisionned with the following script:

Connect our NAS to get JTS installation package

sudo apt-get update sudo mkdir -p /media/installs sudo apt-get install cifs-utils unzip ntp -y sudo mount -t cifs //<nas>/installs /media/installs -o username=vagrant,password=<pwd>,file_mode=0777,dir_mode=0777

# Configure time sync because will also talk with a Windows network
sudo rm /etc/ntp.conf
sudo cp /media/installs/templates/ubuntu/ntp.conf /etc/ntp.conf
sudo service ntp restart

# Get and unzip JTS package
sudo cp /media/installs/IBM/RTC/5.0/JTS-CCM-QM-RM-repo-5.0.1.zip .
sudo chown vagrant:vagrant JTS-CCM-QM-RM-repo-5.0.1.zip
unzip -q JTS-CCM-QM-RM-repo-5.0.1.zip -d ./repo
sudo chown -R vagrant:vagrant ./repo
rm JTS-CCM-QM-RM-repo-5.0.1.zip

# Get and unzip JTS Web Installer package
sudo cp /media/installs/IBM/RTC/5.0/CLM-Web-Installer-Linux-5.0.1.zip .
sudo chown vagrant:vagrant CLM-Web-Installer-Linux-5.0.1.zip
unzip -q CLM-Web-Installer-Linux-5.0.1.zip -d ./webinst
sudo chown -R vagrant:vagrant ./webinst
rm CLM-Web-Installer-Linux-5.0.1.zip

# Deploy JTS
cd ./webinst/im/linux.gtk.x86_64
[ -f ./silent-install-server2.xml ] && rm ./silent-install-server2.xml
sudo cp /media/installs/templates/ubuntu/rtc5-silent-install-server2.xml silent-install-server2.xml
sudo chown vagrant:vagrant silent-install-server2.xml
./userinstc -acceptLicense -showVerboseProgress -input silent-install-server2.xml --launcher.ini user-silent-install.ini

#Configure and start the Tomcat server
cd ~/IBM/JazzTeamServer/server
sudo rm ./conf/jts/teamserver.properties
sudo cp /media/installs/templates/ubuntu/rtc5-teamserver.properties ./conf/jts/teamserver.properties
sudo chown vagrant:vagrant ./conf/jts/teamserver.properties
./server.startup

The silent-install-server2.xml is just modified to contain absolute path a specified by the installation documentation.

Here, JTS is successfully deployed, but not setup. As suggested by Fran├žois-Xavier Panaget, I run...
./repotools-jts.sh -setup responseFile=/home/vagrant/response.properties 
... and after having answered about 20 questions, I get a working JTS.

To complete my automation process, I rename the resulting response.properties file in parameters.properties to complete my script as:
sudo cp /media/installs/templates/ubuntu/rtc5-parameters.properties ./parameters.propertie
sudo chown vagrant:vagrant ./parameters.properties
./repotools-jts.sh -setup parametersFile=parameters.properties 
Then, I always get the following error message:
CRJAZ1357E The repotools command could not log in to the following server: https://localhost:9443/jts. Check the login credentials.
I run this process several times, and I get this error at 100%. Any help would be great. Thanks.


Donald Nong commented Dec 15 '14, 6:33 p.m. | edited Dec 15 '14, 6:34 p.m.

Are you using the default ADMIN/ADMIN credentials? If not, you should specify -adminUserId and -adminPassword or use the -credentialsFile parameter to point to a property file.
http://www-01.ibm.com/support/docview.wss?uid=swg21657881


Romuald Tisserand commented Dec 16 '14, 4:40 a.m.

Thanks Donald,
But to me that doesn't sound logical.

Yes, I changed the admin credentials. And these new credentials are indeed written into the parameters file. So why, put then again in the command line?

But, I've made the test, by running...

./repotools-jts.sh -setup parametersFile=parameters.properties -adminUserId=Admin -adminPassword=<password>


...and I get:
Unrecognized parameters: "-adminPassword", "-adminUserId".
So, I tried to remove the credentials from the properties file (because I put them in the command line)...and same error.

Thanks for the help.


Donald Nong commented Dec 16 '14, 5:53 p.m.

My bad. For some reason I kept repeating the same mistake - for repotools parameters, you don't put a dash(-) in front of them. So your command should look like this

./repotools-jts.sh -setup parametersFile=parameters.properties adminUserId=Admin adminPassword=<password>
or
./repotools-jts.sh -setup parametersFile=parameters.properties credentialsFile=credentials.properties
if you put the credentials in the file called "credentials.properties".


Romuald Tisserand commented Dec 17 '14, 4:16 a.m. | edited Dec 17 '14, 4:16 a.m.

Thanks.

I found the mistake by myself some minutes later, but didn't post because of another issue. I've found the response file must not be modified when used as an input parameters file. I modified it just to group properties and add some empty lines to make the file cleaner and clearer, big mistake.

No, I've something which seems to work, but I've still an issue to confirm, will post later.


Romuald Tisserand commented Dec 17 '14, 10:32 a.m.

I think I've reached a working and reproductible Vagrant script. Great!

The last issue was the following: if you launch "./repotools-jts.sh -setup" just after "./server-startup.sh", the setup will fail with the "Check the login credentials." error. Weird, but real. I fixed this by adding a sleep of few mns between the 2, and then, the setup works.


Donald Nong commented Dec 18 '14, 2:47 a.m.

I have converted your last question to a new "question" on the forum so as to attract more attention.

showing 5 of 9 show 4 more comments

permanent link
Lonnie VanZandt (68216) | answered Oct 29 '15, 6:22 p.m.
 Romuald, Donald,

I see symptoms very similar to Romuald's with Jazz 6.0.1 M5 with LQE, RELM, and JRS included. I suspect what is going on is that the more servlet apps there are (like "ccm", "rm", or "lqe") then the longer it takes Jazz to process the startup for all those apps. I have found that the necessary waiting period between starting the server and running the setup can be surprisingly long. 2 minutes would be spiffy in some cases!

Your answer


Register or to post your answer.