It's all about the answers!

Ask a question

5.0.1 Express Installation Fails


Kenneth Herrscher (1218) | asked Nov 19 '14, 6:46 p.m.

I have installed RTC on a Win 7 VM for evaluation purposes. I started Tomcat7, and it started fine from within the IBM Collaborative Life Cycle Management folder.  However when I try to execute  https://d2003873vm.scrra.net:9443/jts/setup , I receive an HTTP Status 404 error.  I checked C:\Program Files\IBM\JazzTeamServer\server\tomcat\webapps and found that the .war file have not been deployed.

I am stumped here. Can someone help with simple installation assistance?

3 answers



permanent link
Ralph Schoon (55.5k23642) | answered Nov 20 '14, 4:53 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Nov 20 '14, 4:53 a.m.
Don't ever, ever, ever, ....... ever, install CLM into "Program Files" on Windows 7. The folder is virtualized and restricts a lot of operations, unless you explicitly start the server process as administrator - even if the user starting it is administrator.

The problem likely is that tomcat can't create certain folders and files.

I would suggest to uninstall and install again using another folder e.g. C:/CLM/5.0.1/JazzTeamServer to install into.

Comments
Ralph Schoon commented Nov 20 '14, 4:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

PS: I know it is the default location and it should be changed.


Francois-xavier Panaget commented Nov 20 '14, 5:36 a.m.

Hi,

An other option could be to turn off Windows 7 UAC (User Account Control): Turning off/on UAC

Fran├žois


permanent link
Donald Nong (14.3k213) | answered Nov 20 '14, 12:19 a.m.
Check catalina.out file for any errors. If Tomcat starts properly, you should see lines like "INFO: Deploying web application archive " indicating which .war file it deploys.

permanent link
Kenneth Herrscher (1218) | answered Nov 20 '14, 9:59 a.m.

I solved the mystery's of the installation last night and got it to install.  The problem was solved as follows:

Jazz installation process behaves much other Java/Unix apps that have been ported to the Windows platform.  It does not acknowledge rights properly.  My domain and local admin rights were largely ignored by the install process. I had to grant My user id  full rights to the installation path, and had to run the Tomcat start process from the command line by running the command line as Administrator.  That granted Tomcat the rights to deploy the .war files.  Tomcat could not generate a .War file because without being started by an elevated command line, it lacked rights to create it's own folders.

It is now running comfortably in the Program Files directory, x64, and the HTTPS issues were solved by both fixes as well.

IBM's install doc and the install it self for Windows platform is not ready for general release. 


Comments
Ralph Schoon commented Nov 21 '14, 3:49 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This, as stated above, only happens in the Program Files Folder.

Besides that, there are other reasons why you don't want to install there, for example for backup and upgrade considerations, you want a folder where you can distinguish the version you installed.

Your answer


Register or to post your answer.