It's all about the answers!

Ask a question

Rational Insight Data Movement Task fails for Focal Point job


Kunal Bajaj (26510) | asked Nov 11 '14, 1:19 p.m.
Environment: Windows Server 2008 R2, SQL Server 2008 R2, Rational Insight 1.1.1.2 

All jobs are scheduled and are working except for the Focal Point job. This was working without any problems until last week when it stopped running abruptly. There is no error message in the ri_jdbc.log file either. In Insight, I get the following error:
DM-DBM-0400 UDA driver reported the following on connection FocalPoint: UDA-SQL-0107 A general exception has occurred during the operation "prepare". CRRRE9000E: Internal Java error, check ri_jdbc.log for details

However, if I run the job from Data Manager, there is no problem. Not sure what could be causing this. Nothing has changed in our environment either. Any thought/ ideas?

5 answers



permanent link
Kunal Bajaj (26510) | answered Nov 11 '14, 1:23 p.m.
Here is a screenshot of the error:

Comments
Jackie Albert commented Nov 11 '14, 1:24 p.m. | edited Nov 11 '14, 1:25 p.m.

Did you check ri_jdbc.log? Usually that has much more helpful information about the actual error.  There may be multiple versions of ri_jdbc.log, depending on who you are running the scheduled job as vs running as yourself.


permanent link
Kunal Bajaj (26510) | answered Nov 11 '14, 1:30 p.m.
The rijdbc.log file does not contain any error message.

permanent link
Francesco Chiossi (5.7k1719) | answered Nov 14 '14, 5:34 a.m.
Hello Kunal,

is the data manager client on the same machine as the report server?
Did you try to publish the job again?

Best Regards,

Francesco Chiossi

permanent link
Kunal Bajaj (26510) | answered Nov 14 '14, 5:59 a.m.
Francesco,

Yes, this is an All in One environment. We republished the job and it works fine. We want to isolate the issue in case it happens again. 

Thanks.

Kunal

permanent link
Francesco Chiossi (5.7k1719) | answered Nov 14 '14, 7:27 a.m.
Hello Kunal,

good to hear that a republishing fixed it.

Usually the Internal Java error means that something went wrong with the XML ODBC Driver.
That's why it mentions to check for
ri_jdbc.log.
If there are no errors there maybe the XML ODBC Driver process just died.
You might want to check if the connection sequence in the driver is complete at the time of the error (comparing with one from a working instance) or what was the last action in the log.

When you publish a job there are some catalog information that are passed over, so changes in the ETL or the configuration of the ODBC sources might sometime require a republishing.

If no such changes occurred, it's definitely strange that the job suddenly started to fail.

Best Regards,

Francesco Chiossi

Your answer


Register or to post your answer.