It's all about the answers!

Ask a question

Missing folders while configuring the WebSphere Application Server as a service for RAM


anoop mc (75010147205) | asked Sep 03 '14, 2:47 a.m.
 Hi,

  While trying to configure the WebSphere Application Server to run as a service for RAM I have followed the below guide 

http://pic.dhe.ibm.com/infocenter/ramhelp/v7r5m1/index.jsp?topic=%2Fcom.ibm.ram.doc%2Ftopics%2Fc_integrate_jazz_overview.html

Section: Configuring the embedded WebSphere Application Server as a service 

Following the command syntax  - WASService.exe -add RationalAssetManager -serverName server1 -profilePath "C:\Program Files\IBM\RAMServer\ram\ewas\profiles\profile1" -wasHome "C:\Program Files\IBM\RAMServer\ram\ewas" -stopArgs "-username admin -password admin" -startType automatic

In my RAMServer installation directory I could not find the directories ewas\profiles\profile1 

Now I am starting the WAS service manually and when logging out of the server it stops automatically by running the below command.

G:\Program Files (x86)\IBM\WebSphere\AppServer\profiles\AppSrv01\bin>startServer.bat server1
Any Suggestions ?




Comments
Ary Zhang commented Sep 03 '14, 4:23 a.m.
JAZZ DEVELOPER

Hi,
Why do you need conifgure the embeded WAS? I think you even haven't installed it. And embeded version has been abandon as my knowledge. It was WAS 6.0 time.
Only embeded version of WAS has the folder. Your WAS is not embeded version.
Thanks a lot. :-)

Accepted answer


permanent link
Donald Nong (14.4k213) | answered Sep 03 '14, 4:41 a.m.
edited Sep 03 '14, 4:42 a.m.
Try to understand the parameters in the command first. It will make your life easier. :-)
The command that you need to run is
"G:\Program Files (x86)\IBM\WebSphere\AppServer\bin\WASService.exe" -add RationalAssetManager -serverName server1 -profilePath "G:\Program Files (x86)\IBM\WebSphere\AppServer\profiles\AppSrv01" -wasHome "G:\Program Files (x86)\IBM\WebSphere\AppServer" -stopArgs "-username admin -password admin" -startType automatic
Change the username and password accordingly if they are not admin/admin.
If you specify the wrong username/password for the -stopArgs parameter, you can never stop the WAS Windows service properly (a prompt for the correct username/password will open in nowhere).
If you find that you give the wrong value to the parameters, simply remove the service first and add it back with the correct values.
"G:\Program Files (x86)\IBM\WebSphere\AppServer\bin\WASService.exe" -remove RationalAssetManager

anoop mc selected this answer as the correct answer

Your answer


Register or to post your answer.