It's all about the answers!

Ask a question

The LDAP user search base does not exist while running RAM Setup


anoop mc (75010149206) | asked Sep 02 '14, 7:35 a.m.
 Hi,

We are getting an error message and is unable to proceed further with the RAM setup.

While specifying the administrator for WAS and RAM. Clicking the Verify User button throw an error saying the LDAP user search base does not exist.

 The administrator id shown is the current Jazz Repository Admin which has been configured in WAS. When enabled the default admin account got disabled.

ldap_error


Comments
Donald Nong commented Sep 02 '14, 11:23 p.m.

Is that a comma(,) at the beginning of the string that you put in for "User search base"? If so, remove it.


anoop mc commented Sep 02 '14, 11:49 p.m.

I have tried removing the comma but still the same issue. 


Donald Nong commented Sep 03 '14, 4:47 a.m.

Not sure about the exact configuration of your LDAP, but if the "suggested value" in the screenshot is anything to trust (maybe you configured it somewhere else before), you cannot remove the leftmost "DC" from the DN. Why do you want to do that? Just imagine, can you use "DC=com" as the base?

2 answers



permanent link
Ary Zhang (2474) | answered Sep 02 '14, 9:19 p.m.
JAZZ DEVELOPER
Hi.
That means RAM can not search through DC=uis,DC=***,DC=com. The path is invalid. Please check it ,you could use the third part application such as ldapbrowser to check.
By the way, RAM's account management is different from RTC. And the administrator ID should be the LDAP administrator id, not RAM's , not RTC's.

Thanks a lot.

Comments
anoop mc commented Sep 02 '14, 11:55 p.m.

 You mean to say softerra ldap browser.

  Let me brief what I have done:
1. After Installing RAM and WAS and DB2.

2. I could login using admin/admin credential.

3. I went to WAS integrated console. Under Security registered my user as the primary administrator while configuring the LDAP settings.

4. From then on I could use only my domain login for logging into WAS and RAM even for stopping the WAS service.

5. While proceeding with the RAM setup, when logged in with my account at the final stage it was giving me the said error and even administrator option is not available.


Ary Zhang commented Sep 03 '14, 4:27 a.m.
JAZZ DEVELOPER

Hi, it would not work I think.
If you want to set up LDAP , you have to go to the very first step of RAM setup and select "LDAP" in "Authentication type", and go through all the steps.
And if you want your account be the repository admin , you have to grant the permission in LDAP server, not in WAS.
Thanks a lot.


permanent link
anoop mc (75010149206) | answered Sep 05 '14, 2:50 a.m.
 We could resolve the issue by working with the Server Team and trying with a different LDAP Server name where it got verified and we could proceed with the next step.

In the final stage Clicking Finish button took us to the RAM Login Page and Administration option was enabled for the account.

Your answer


Register or to post your answer.