It's all about the answers!

Ask a question

JTS Startup Process Hangs in Command Window


Scott McBride (12510) | asked Aug 28 '14, 2:09 p.m.
I am suddenly unable to successfully start Jazz Team Server.  Up to this point, I have been able to successfully start JTS by invoking the startup batch program as an Administrator.  (I have the full CLM v5.0 suite installed in a Windows 7 machine for demonstration and learning purposes.)

I have rebooted my machine, but the startup process still hangs. 

The last line in the command window is "... 11 more".  Next line is the flashing cursor.

[I just tried inserting a image of the command window but the question editor came back with an error of its own!]

I have stopped and then started the JTS multiple times, each with the same result: upon starting, it will show the progress in the command window, and then hang.  Of course, the final message I am looking for is the elapsed time required for JTS - that's my indication that I can log in.

Any advice/solutions would be most appreciated!

Comments
Donald Nong commented Aug 28 '14, 8:29 p.m.

If you see "... 11 more" in the command window, it means that you get Java stack trace displayed there, which means that exceptions are thrown during startup. If you cannot scroll up the command window to see the entire stack trace, check the log file tomcat/logs/catalina.out (which contains the same messages as displayed in the command window) and/or tomcat/logs/catalina.<date>.log.

One answer



permanent link
Alex Akilov (1211224) | answered Aug 28 '14, 2:26 p.m.
I would look at the jts.log (in .../server/logs) to see what's really happening.

Comments
Scott McBride commented Aug 28 '14, 2:37 p.m.

Alex,
Here are the last sever lines in C:\Program Files\IBM\JazzTeamServer\server\tomcat\work\Catalina\localhost\vvc\eclipse\workspace.metadata.log:

!ENTRY org.eclipse.osgi 4 0 2014-08-28 10:55:32.061
!MESSAGE Bundle # javax.servlet.jsp@start not found.
!SESSION 2014-08-28 11:14:27.622 -----------------------------------------------
eclipse.buildId=unknown
java.fullversion=JRE 1.6.0 IBM J9 2.4 Windows 7 amd64-64 jvmwa6460sr15-20131231_180656 (JIT enabled, AOT enabled)
J9VM - 20131231_180656
JIT  - r9_20130920_46510ifx3
GC   - GA24_Java6_SR15_20131231_1152_B180656_CMPRSS
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

!ENTRY org.eclipse.osgi 4 0 2014-08-28 11:14:27.622
!MESSAGE Bundle # org.eclipse.equinox.jsp.jasper@start not found.

!ENTRY org.eclipse.osgi 4 0 2014-08-28 11:14:27.622
!MESSAGE Bundle # org.eclipse.equinox.jsp.jasper.registry@start not found.


What are the implications of the "not found" messages?

Any recommendations?

Thx.


Alex Akilov commented Aug 28 '14, 2:41 p.m.

Back up to C:\Program Files\IBM\JazzTeamServer\server\logs\jts.log.  The .metadata.log is for something else

Your answer


Register or to post your answer.