It's all about the answers!

Ask a question

Deliver Error in RTC


Aditya Mondal (1111) | asked May 14 '13, 1:56 a.m.
edited May 15 '13, 2:47 a.m.
When I'm trying to deliver a component in RTC. It gives an error:

----------------------------------------------------------
Error logged from Process Client UI:
XPCOM error -2147467259
----------------------------------------------------------
My Jazz Server is connected fine and it shows connected in RTC.

I tried this on my ubuntu:

>>> ldd libswt-mozilla-gtk-3659.so

linux-vdso.so.1 =>  (0x00007ffff5bff000)
libxpcom.so => not found
libnspr4.so => /usr/lib/x86_64-linux-gnu/libnspr4.so (0x00007ffc49b3e000)
libplds4.so => /usr/lib/x86_64-linux-gnu/libplds4.so (0x00007ffc49939000)
libplc4.so => /usr/lib/x86_64-linux-gnu/libplc4.so (0x00007ffc49734000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ffc49431000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ffc49134000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ffc48f1e000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ffc48b5f000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ffc48941000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ffc4873d000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007ffc48535000)
/lib64/ld-linux-x86-64.so.2 (0x00007ffc49eb6000)

Comments
Jared Burns commented May 14 '13, 11:19 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
This is a problem related to Xulrunner and SWT. Have you seen this similar question? https://jazz.net/forum/questions/72508/xpcom-error-2147467262-with-64bit-client-ext-on-linux-mint

Did you try any of the proposed solutions?

One answer



permanent link
Rajat Singh (59833442) | answered May 14 '13, 2:05 a.m.
It appears like you are hitting the below defect:


Try the workaround in the article mentioned in comment 6.




Comments
Aditya Mondal commented May 14 '13, 2:16 a.m.

Nope that makes no difference.


Aditya Mondal commented May 14 '13, 2:41 a.m.

My RTC, xulrunner, firefox all are 64 bit

Your answer


Register or to post your answer.