It's all about the answers!

Ask a question

Test Plans not showing on RQM DW Reports


Taly Hotimsky (2563156) | asked Aug 12 '14, 6:15 p.m.
We're using RQM 4.0.6 and Test Plans are not being loaded to DW Reports even though Data Collection Jobs are running successfully (as verified on the admin >> reports page).
We verified this for several users/browsers, ruling out a problem with individual configurations or cookies.

What are other common causes that'd prevent the Test Plans from showing on the reports?
Thanks!

2 answers



permanent link
Benjamin Silverman (4.1k69) | answered Aug 12 '14, 6:41 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Taly,

Usually when folks report they can't see data, it's because they are not members of the project area they are expecting to see data from.  The report model has a filter that prevents users without access to projects from seeing data in those projects.  If that's the case, you need to either deploy the unsecure report model, or add yourself to any/all projects you need to see data from and re-run the ETL's so your user is associated with those projects in the DW. 

Sounds like you've tried with a number of users though, so maybe this isn't your problem.  Can you see other data, and are all test plans missing or just some?  How are you validating that the test plans are not returned (ie - running one of our out of the box reports, have you tried a simple report from query studio, checked directly in the RIODS.TESTPLAN table for the data, etc..)?

Comments
Taly Hotimsky commented Aug 12 '14, 7:57 p.m.

Hi Benjamim.


I should've included in the original post that all users we tried with are both admins for the PA and have the Test Team Member role there. There's only one PA in this project, so I don't think that security is what's causing the issue.

I can see some Test Plans, but none that were created today (even though we made sure the data collection jobs ran after the Test Plans were created). We've noticed this for pretty much all the DW Reports OOTB we tried, both from the dashboard (as widgets based on those reports) and as reports directly from the RQM Reports menu.
We didn't try pulling the data any other way (and I'm not sure what those other ways are - I don't know what you mean by query studio or RIODS TESTPLAN) 


Benjamin Silverman commented Aug 12 '14, 10:44 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Do you have RRDI installed?  If so you can use Query Studio to create a report that shows your test plans.  Otherwise, I would suggest investigating from the database side to see if the test plans are in the database.  You can look in the Data Warehouse table RIODS.TESTPLAN, which is where the test plans get loaded when you run the ETL.  For example, SELECT * FROM RIODS.TESTPLAN will return a listing of all test plans that have been loaded in to the DW.


permanent link
Taly Hotimsky (2563156) | answered Aug 13 '14, 1:09 p.m.
We realized the "problem" was in the data collection jobs.
Not all apps (QM, CCM, RM, JTS) were set to run hourly, that's why some data was updated on the reports, some wasn't.

Your answer


Register or to post your answer.