It's all about the answers!

Ask a question

DM - Linking a RRC Artifact using "Derives From" link


Alberto Teodoro (6631631) | asked Aug 11 '14, 11:23 a.m.
edited Aug 11 '14, 11:47 a.m. by Stef van Dijk (2.0k79)
Hi all,
I would like to link my DM elements to the RRC Artifacts.
I'm using CLM 4.0.6.
The best practise, advices to use the "Derives From" link type.

If I use this link type, the bi-directonal link, it works, but, for me the details from the RRC side are not right.
In fact:
1) in a DM elemnet (i.e. an Interface) the link to the RRC Artifact shows, in the "Links" tab, under the "Derives From", the Name of the Artifact with the ID, and the hyperlink is masked by this information (see the picture)
Derives From, DM view
2) In the RRC Artifact, in the Links part (on the right side), under the "Derives" section,  I can see only the Hyperlink, without the masking of the name and ID of the DM element (see the picture below)
Derives, RRC view
3) If I use the "Diagram view of related links", I can't see no information about the "Derives" Links and the hyperlinks are not showed for the browsing (see the picture below)
Diagram view of related links
I've also tried to use other link types, such as "References", "Related to" or "Elaborates", both the RRC and DM side, but they have not the bi-directonal feature.

Someone has the same behaviour? 

My best regards
Alberto


Accepted answer


permanent link
Stef van Dijk (2.0k79) | answered Aug 11 '14, 11:56 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
In the past when I've seen urls appear in place of the name/id like you describe it's because there is an issue accessing the url location (or possibly the friends configuration). What happens if you actually click on the hyperlink. Does it successfully navigate to the artifact in Design Manager?
Rosa Naranjo selected this answer as the correct answer

Comments
Alberto Teodoro commented Aug 11 '14, 12:35 p.m. | edited Sep 19 '14, 3:57 p.m.

Hi Stef,

many thanks.
 
Yes, I can successfully navigate to the artifact in Design Manager and vice-versa.
I can't navigate to the DM element from "Diagram view of related links".

Tell me if you have advices for a best friends configuration.

Ciao
Alberto


Stef van Dijk commented Aug 12 '14, 10:54 a.m. | edited Sep 19 '14, 3:57 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

If navigating works then usually that means the friend configuration is fine.
One other thing I noticed is that you are using the default port (443), so I'm wondering if the fact that the url does not specifically contain that, that it's resulting in a mismatch and preventing the "pretty" label from being fetched.
To be honest, it might be best to report this to support (http://www-01.ibm.com/software/rational/support/contact.html) so they can investigate this in more detail than we can cover via this forum.

Your answer


Register or to post your answer.