It's all about the answers!

Ask a question

RTC client 4.0.3 crashes when Delivering a Change Set


Giulio Fiscella (611) | asked Jul 09 '14, 5:04 a.m.
edited Jul 13 '14, 9:40 p.m. by Jennifer Cianchetta-Riordan (2512)
Hi!
I have no idea what is causing this issue, so I will try to give as much information and background as possible.

I am using RTC client 4.0.3 (same version as the one installed on our server).
We are using RTC in our team to manage the source code for a project.
The process to make changes is:
- create a change set
- associate it to a work item
- request for a review
- once approved deliver the change set

I have been using it on my computer running Ubuntu OCDC 12.04 (IBM J9 VM build 2.4, JRE 1.6.0) with no problem.
I decided to upgrade to Ubuntu OCDC 14.04 (that comes with IBM J9 VM build 2.6, JRE 1.7.0).
I forgot that I had a couple of change sets waiting for approval but I still had a backup of the single files I modified (not the whole workspace directory).
So, after the upgrade I reinstalled the RTC 4.0.3 client and checked the status of my work items. Every time I tried to open the change set associated with the item window, the client would crash after a short while. I suspected the reason was that the client was looking for the changes in my local machine and could not find them.
Somehow, in the short period before the crashes, I managed to remove the not yet delivered change sets from the affected work items.
I experienced some crashes when accepting some unrelated change sets but other than that I thought I solved the problem.
I then used my backup to reapply the changes and asked again for a review.
I now have an approval but whenever I try to deliver the change set the client systematically crashes.

How can I fix this?
Is it an incompatibility problem between the 4.0.3 client and 14.04/newer java?
Or is it a problem because of the change sets I lost with the upgrade?

This is the error I get when I launch the client from a terminal, I can provide the dumped java files if needed:
Unhandled exceptionType=Segmentation error vmState=0x00000000J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=00000000 Signal_Code=00000001Handler1=00007FDF509AAB40 Handler2=00007FDF50663FF0 InaccessibleAddress=0000000000000000RDI=0000000000000000 RSI=00007FDF4D1308E0 RAX=00007FDF4F3CCB30 RBX=0000000000000000RCX=0000000000000001 RDX=00007FDF5235E968 R8=0000000000000000 R9=00007FDF4C0A5310R10=00007FDF5153BC70 R11=00007FDF5153BD70 R12=0000000000000004 R13=0000000000000119R14=00007FDF50B123C0 R15=00007FDE6422FA2ARIP=00007FDE2FCBF2A1 GS=0000 FS=0000 RSP=00007FDF5153C090EFlags=0000000000210206 CS=0033 RBP=00007FDF4D1308E0 ERR=0000000000000004TRAPNO=000000000000000E OLDMASK=0000000000000000 CR2=0000000000000000xmm0 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm1 2424242424242424 (f: 606348352.000000, d: 1.385533e-134)xmm2 00007fdf4c698538 (f: 1281983744.000000, d: 6.946417e-310)xmm3 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm4 00000000ff000000 (f: 4278190080.000000, d: 2.113707e-314)xmm5 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm6 00007fdf5153c520 (f: 1364444416.000000, d: 6.946421e-310)xmm7 0000000000000004 (f: 4.000000, d: 1.976263e-323)xmm8 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm9 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm10 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm11 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm12 0000000000000000 (f: 0.000000, d: 0.000000e+00)xmm13 00000000437f0000 (f: 1132396544.000000, d: 5.594782e-315)xmm14 0000000037800000 (f: 931135488.000000, d: 4.600421e-315)xmm15 0000000000000000 (f: 0.000000, d: 0.000000e+00)Module=/usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1Module_base_address=00007FDE2FC53000 Symbol=soup_session_feature_detachSymbol_address=00007FDE2FCBF290Target=2_40_20130114_134867 (Linux 3.13.0-30-generic)CPU=amd64 (8 logical CPUs) (0x3d47e8000 RAM)----------- Stack Backtrace -----------soup_session_feature_detach+0x11 (0x00007FDE2FCBF2A1 [libsoup-2.4.so.1+0x6c2a1])Java_org_eclipse_swt_internal_webkit_WebKitGTK__1soup_1session_1feature_1detach+0x7f (0x00007FDE6422FAA9 [libswt-webkit-gtk-4236.so+0x5aa9])(0x00007FDF509C0C05 [libj9vm24.so+0x2ac05])---------------------------------------JVMDUMP039I Processing dump event "gpf", detail "" at 2014/07/08 09:14:44 - please wait.JVMDUMP032I JVM requested System dump using '/home/giuliofi/core.20140708.091444.9738.0001.dmp' in response to an eventJVMPORT030W /proc/sys/kernel/core_pattern setting "|/usr/share/apport/apport %p %s %c %P" specifies that the core dump is to be piped to an external program.  Attempting to rename either core or core.16667.JVMDUMP010I System dump written to /home/giuliofi/core.20140708.091444.9738.0001.dmpJVMDUMP032I JVM requested Java dump using '/home/giuliofi/javacore.20140708.091444.9738.0002.txt' in response to an eventJVMDUMP010I Java dump written to /home/giuliofi/javacore.20140708.091444.9738.0002.txtJVMDUMP032I JVM requested Snap dump using '/home/giuliofi/Snap.20140708.091444.9738.0003.trc' in response to an eventJVMDUMP010I Snap dump written to /home/giuliofi/Snap.20140708.091444.9738.0003.trcJVMDUMP013I Processed dump event "gpf", detail "".















































2 answers



permanent link
Tim Mok (6.6k38) | answered Jul 09 '14, 8:58 a.m.
JAZZ DEVELOPER
It looks like a xulrunner issue with your new OS install. I don't think Ubuntu 14.04 installs xulrunner by default anymore. Check your install repo for xulrunner or find one compatible with the version of Eclipse that you are using.


Comments
Giulio Fiscella commented Jul 09 '14, 9:11 a.m.

I do not think I have xulrunner installed, I cannot find it in any of the usual directories


Tim Mok commented Jul 09 '14, 11:05 a.m.
JAZZ DEVELOPER

That's your issue. You don't have it installed.


-1
permanent link
Piotr Aniola (3.7k1635) | answered Jul 09 '14, 7:10 a.m.
RTC 4.0.3 client should be compatible with Java 1.7:
https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements403#B5_Java_SDK_RTC_Eclipse_Client

For this sort of issue I believe it is better to open a PMR with IBM Support, or file a defect on jazz.net, if you don't have a support contract.

Comments
Giulio Fiscella commented Jul 09 '14, 9:25 a.m.

Opened Defect 323718

Your answer


Register or to post your answer.