It's all about the answers!

Ask a question

Rational Build Forge doesn't work with Websphere Aplication Server - Error ProxyServlet


Antonio Carlos Lacerda Dias (32914) | asked Jun 26 '14, 4:23 p.m.
edited Jun 26 '14, 4:39 p.m.
 Hi,

We installed Websphere Application Server instead Tomcat to run Build Forge in the same server.  The WebSphere and Build Forge were installed and configured based on reference links cited below.

We tried run Build Forge on link https://localhost:9443/jas but doesn't worked, showed the message "Error 404: ProxyServlet /jas". I guess is missing some mapping but I don't know where stay.

We performed all steps from links references but doesn't worked.

WAS reference link: http://pic.dhe.ibm.com/infocenter/bldforge/v7r1m3/index.jsp?topic=%2Fcom.ibm.rational.buildforge.doc%2Ftopics%2Fconfig_integrations_websphere_was.html

Build Forge reference link: http://pic.dhe.ibm.com/infocenter/bldforge/v8r0/topic/com.ibm.rational.buildforge.doc/topics/install_mc_installer_steps.html


WAS: 8.5.0.0
Build Forge: 8.0.0.2
OS: Linux Red Hat 6 Srv

Comments
Donald Nong commented Jun 26 '14, 9:14 p.m.

Check the SystemOut.log file of your WAS. You should see messages about starting the web application and binding the web application to certain ports.


Antonio Carlos Lacerda Dias commented Jun 30 '14, 7:48 a.m.
Hello Donald,

I checked  SystemOut.log file of your WAS and and show this message:
com.buildforge.services.common.api.APIException: CRRBF2007I: Unexpected exception: java.net.BindException: Address already in use

I reviewed all the WAS configuration and BF and I could not identify the problem. WAS and BF are installed with the settings suggested in the installation. 

More informations:
- Our server is not available for external access just internal access.

WAS is installed and configured as default:
- Administrative console port: 9060,  Administrative console port Secure : 9043, HTTP transport port: 9080, HTTPS transport port: 9443, Bootstrap: 2809,SOAP connector port: 8880

Build Forge configuration:
- HTTP: 9080,HTTPS: 9443,List port: 3966,Listen on Secure port: 49150

<o:p> </o:p>

One answer



permanent link
Antonio Carlos Lacerda Dias (32914) | answered Jul 18 '14, 8:28 a.m.
 Hi,

We got solve this issue. There are more than one build forge services running. We stopped and kill process and restart the services and worked.

Thanks all.

Your answer


Register or to post your answer.