It's all about the answers!

Ask a question

"ignored resources" are NOT excluded from source c


Maarte Oerlemans (665) | asked Oct 15 '07, 7:46 a.m.
We are using Visual Studio, because that is the default development environment. Visual Studio creates some directories to store derived objects, like the *.exe files and debug files.
These directories and files should not be under source control. So, we configured that the directories "bin" en "debug" should be excluded from source control.
This was done in Windows - Preferences - Team - Ignored Resources.

By building an application the directories are created by Visual Studio, as expected. Jazz creates an out-going change set containing the created directories with their contents.
That behaviour was not expected.

How can we exclude these directories from source control?
Or did we find a bug?

5 answers



permanent link
Evan Hughes (2.4k1118) | answered Oct 15 '07, 9:32 a.m.
JAZZ DEVELOPER
Hi,

Jazz does not currently respect Team ignores defined via "Windows >
Preferences > Team > Ignored Resources". Instead you must mark resources
as ignored by selecting the resource in the Navigator or Package
Explorer and open "Team > Add to Ignore List" from the context menu.

e

moerlema wrote:
We are using Visual Studio, because that is the default development
environment. Visual Studio creates some directories to store derived
objects, like the *.exe files and debug files.
These directories and files should not be under source control. So, we
configured that the directories "bin" en "debug"
should be excluded from source control.
This was done in Windows - Preferences - Team - Ignored Resources.

By building an application the directories are created by Visual
Studio, as expected. Jazz creates an out-going change set containing
the created directories with their contents.
That behaviour was not expected.

How can we exclude these directories from source control?
Or did we find a bug?

permanent link
Patrick Oor (21) | answered Oct 16 '07, 3:34 a.m.
Hi Evan

Also the "Team > Add to Ignore List" does not work:

- the obj directories are marked as ignored
- but the bin directories are not
- and both appear as pending changes

Please fix.

Patrick.

permanent link
Patrick Oor (21) | answered Oct 16 '07, 8:45 a.m.
As a follow-up on my previous message, it seems to work now.

Thanks,
Patrick.

permanent link
Jean-Michel Lemieux (2.5k11) | answered Oct 16 '07, 8:46 a.m.
JAZZ DEVELOPER
It would be interesting to find out what you did to 'fix' your situation. Could we improve things here to make this easier?

permanent link
Evan Hughes (2.4k1118) | answered Oct 19 '07, 9:32 a.m.
JAZZ DEVELOPER
Hi Patrick,

Can you reproduce the situation where "Team > Add to Ignore List"
does not work?

e

oorp wrote:
As a follow-up on my previous message, it seems to work now.

Thanks,
Patrick.

Your answer


Register or to post your answer.