It's all about the answers!

Ask a question

maven build skipping goal?

wee anon (111) | asked Aug 21 '12, 9:05 a.m.

I have two Maven projects under the same component in RTC, one web project and one applet project (I'll call them "web" and "applet").

so, in the root folder of my SRC component, I have a folder "/web", a folder "/applet" and a pom.xml file that build both projects together. each project also has its own pom.xml inside its folder, and the root pom.xml is a "packaging" pom that coordinate them both.

my "applet" project is just a simple maven project. nothing customized.

in my "web" project, I added a few plugins to make the magic happen. I added a "maven-dependency-plugin" in the "prepare-package" step, to copy the "applet" jar into the "web" files, so it is packaged together. this step is working fine.

in the same "prepare-package" goal, I also added a "maven-antrun-plugin" that signs my applet jar, before it is packaged. this step is also working fine and smooth when I run Maven from command-line.

but when I run Maven with RTC, usign a build definition and a build engine I set up, the signing step is just skipped! itdoes not appear in the execution log. no error is thrown, no log is generated, nothing. and then my applet is simply packaged without signing (and so, of course, it fails to run later).

I'm using the same Maven (3.0.4), on the same machine, and calling Maven the same way ("mvn clean install" on command-line, and "clean install" goals on RTC build definition), over the same pom.xml (the root one). I use "root" on command-line to call Maven, and I start the jbe build engine as root too, so I believe both cases run with the same user too. I'm using RTC in a Red Hat system.

and ideia, experience, on why the second prepare-package plugins is being skipped under RTC?

thanks in advance

One answer

permanent link
wee anon (111) | answered Aug 23 '12, 9:31 a.m.


it was an error in the pom.xm file: I should have used two <execution> tags in the antrun-plugin, and not declared the plugin twice in the pom.xml file.


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.