It's all about the answers!

Ask a question

ETL jobs not running on schedule


Luca Martinucci (942277103) | asked Mar 28 '14, 8:30 a.m.
I am working on a RTC-RQM environment (version 4.0.5).
When I explicitly request the execution of ETL jobs, all jobs succeed.
Anyway, I noticed that CCM (RTC) jobs are not executed on schedule, unless JTS and QM jobs.
Where can I check whether CCM jobs are scheduled for nightly run?

Accepted answer


permanent link
Piotr Aniola (3.6k1534) | answered Mar 28 '14, 8:40 a.m.
Hello,

under: https://<host>:9443/ccm/admin#action=com.ibm.team.repository.admin.configureAdvanced
you will find the properties:
Data Collection Jobs Enabled (whether ot not the ETLs will be run), and
Task Delay (
The time interval in seconds between runs of this task. Please do not change).
Luca Martinucci selected this answer as the correct answer

Comments
Luca Martinucci commented Apr 04 '14, 3:39 a.m.

Piotr,


Data Collection Jobs Enabled is set to true; Task Delay is set to 86400.
IsSnapshotEnabled set to true for all jobs.
Is there anything else I should check?
I would like to increase the verbosity of ETL logs (set it temporarily to TRACE or DEBUG) in order to guess why the CCM jobs don't run on schedule.
Which properties should I set in log4j.properties?

One other answer



permanent link
Francesco Chiossi (5.7k1719) | answered Mar 28 '14, 8:40 a.m.
Hello Luca,

as far as I know the data collection job execution is driven by JTS, as the jobs need to be executed in a specific sequence; so only JTS has the schedule setting.
From the description it sounds like a communication issue between JTS and CCM at the time the ETL is scheduled to start; might be worth having a look at the application logs for both.

Best Regards,

Francesco Chiossi


Your answer


Register or to post your answer.