It's all about the answers!

Ask a question

Having problems extracting test result data from RQM using RPE


Joe Gariano (883037) | asked Mar 13 '14, 10:53 a.m.
I have test case result data in an RQM project, and I'd like to create an RPE template that extracts that data (e.g. for making a document that says "this test was run at this time and it passed/failed").  I have experience writing RPE templates that pull other information from RPE (e.g. test case data, test plan data).  But I'm struggling with the test result stuff.  I'm using RPE 1.2 and RQM 4.0.2.  Here's the specific issue I'm having...

The following URI works fine for me, to get me a list of all test case results:
https://gdqm01.gddsi.com:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_FlexCrypto/executionresult

Using the feed.xsd schema on that URI, I'm able to grab the feed entries, and from there grab a URI to the test case result itself (either using the id field or the link href alternate field).  That URI for the first entry in my feed is this:
https://gdqm01.gddsi.com:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_FlexCrypto/executionresult/1528431421

Next, I attempt to dynamically configure another data using that URI, in an attempt to get the detailed information about that test case result.  I've tried using both the executionresult.xsd and qm.xsd schemas for that.  But in both cases, RPE comes back at me with the following error message:
CRRPE1064I Using URL: https://gdqm01.gddsi.com:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_FlexCrypto/executionresult/1528431421.
CRRPE1064I Cannot access https://gdqm01.gddsi.com:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_FlexCrypto/executionresult/1528431421. Verify that URL, user name and password are correct. Error is: Server response code 401 for https://gdqm01.gddsi.com:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_FlexCrypto/executionresult/1528431421

I've seen this error before in past RPE work, and it usually means that the URI I'm supplying is not valid (e.g. has an invalid format).  But I'm stumped in terms of what the URI should be to take me to the specifics of the test case result.

Any help would be appreciated, thanks.
Joe Gariano

3 answers



permanent link
Paul Slauenwhite (8.4k12) | answered Mar 13 '14, 11:02 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hi Joe,

The executionresult URL looks good, assuming the external ID of the executionresult resource is 1528431421.  If you are getting the URL from the executionresult feed, I would expect the URL to be correct.  I would suggest trying the URL in Poster and/or HttpRequester.  Check if the response code/content is 200 (OK)/executionresult XML.  Otherwise, check your RQM log for relevant errors.

Comments
Joe Gariano commented Mar 13 '14, 11:19 a.m.

Thanks Paul.  I couldn't fit my response in this field, so I added it under "your answer".  Any thoughts on the next steps to take?


permanent link
Joe Gariano (883037) | answered Mar 13 '14, 11:19 a.m.
edited Mar 13 '14, 11:25 a.m.
Thanks Paul.  Bear with me as this is my first time using Poster...

I used the URL in Poster and told it to do a get, and it comes back with the content below.  It doesn't appear to be choking, but what it comes back doesn't look like something RPE can parse.
Poster output

Comments
Paul Slauenwhite commented Mar 13 '14, 11:26 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Looks like you are not logged in to RQM from your Firefox browser.

Note, I removed the response content (HTML) since it was not displayed correctly and I could not respond to the post.


Joe Gariano commented Mar 13 '14, 11:29 a.m.

Paul,

I verified I'm logged in to the RQM project in Firefox, then I reran the get with Poster and got the same message back as is shown in the image above.  What's next?

Thanks,
Joe


Paul Slauenwhite commented Mar 13 '14, 11:33 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Did you use the following request header?:

Accept = application/xml

Also, can you open the executionresult but entering https://gdqm01.gddsi.com:9443/qm/service/com.ibm.rqm.integration.service.IIntegrationService/resources/QM_FlexCrypto/executionresult/1528431421 in your web browser?


Joe Gariano commented Mar 13 '14, 11:42 a.m.

I configured the header as shown in the image below, and got back a different result as shown in the image below that.

In terms of the question about the browser, if I put that link in the browser, I'm taken to the test case result in the web UI, but it has a different URL in the Firefox omnibar, namely:
https://gdqm01.gddsi.com:9443/qm/web/console/QM_FlexCrypto#action=com.ibm.rqm.planning.home.actionDispatcher&subAction=viewResult&resultItemId=_X4CwEIdmEeOkY9qwMz_a7w


Joe Gariano commented Mar 13 '14, 11:42 a.m.

header config


Joe Gariano commented Mar 13 '14, 11:43 a.m. | edited Mar 13 '14, 11:43 a.m.

new poster output


1
Paul Slauenwhite commented Mar 13 '14, 11:59 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

OK, you proved the execution result exists both via Poster (executionresult XML) and RQM UI (Test Case Result editor).  From your original post, looks like your RQM user credentials are incorrect in RPE and/or the RQM user does not have read access to executionresult resources (my bet is on the former).


Joe Gariano commented Mar 13 '14, 12:21 p.m.

Thank you Paul...  Reading that your last post reminded me that we recently changed the way our CLM applications and authentication server are configured.  I had forgotten to to tell the dynamically configured data source to inherit the credentials of the data source that I configured in the .dsx file (which I now need to do given the new server set up).  After doing that, I'm now able to access data (specifically, the starttime value) from each test case result using the URI I put in poster and the qm.xsd schema.

One additional question for you... Though the authentication was fine, I was unable to extract the starttime value using the executionresult.xsd schema.  Why is it that the qm.xsd schema worked for that but not the executionresult.xsd schema?  Will the latter schema be needed for other types of test case result data, or will the qm.xsd schema suffice for everything I want to get from a test case result?  (I've never understood the real difference between the feed.xsd, qm.xsd, and other .xsd schemas, I just know they have different structures).

Thanks,
Joe


Paul Slauenwhite commented Mar 14 '14, 2:04 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

Hi Joe,

I would suggest using the RQM XML detailed schema documentation (https://jazz.net/wiki/bin/view/Main/RqmApi#Detailed_Schema_Documentation) to determine which schema contains a particular resource/property.  For example, see https://jazz.net/products/rational-quality-manager/api-doc-4.0.6/schemas/executionresult_xsd/elements/starttime.html for er:starttime:

Defined: globally in executionresult.xsd; see XML source

showing 5 of 9 show 4 more comments

permanent link
Subramanya Prasad Pilar (4.5k14) | answered Mar 13 '14, 1:43 p.m.
Have you provided username/password for all the data sources (including dynamic data source)? You can also "Inherited data configuration" property of Data Source Configuration element to inherit username/password from another datasource.

Comments
Joe Gariano commented Mar 13 '14, 1:44 p.m.

Yes, that was the fix that Paul helped me identify.  Thanks for checking in.

Your answer


Register or to post your answer.