It's all about the answers!

Ask a question

Error received when accessing a specific plan


Namit Pande (6311317) | asked Mar 11 '14, 1:36 p.m.
Hi,
I am on clm 4.0.5 and from the RTC web client, I am receiving the error when I access a specific plan.
TypeError: Cannot read property 'length' of undefined
TypeError: Cannot read property 'length' of undefined

This is the similar error as to:
https://jazz.net/forum/questions/92569/error-when-loading-plan
or
https://jazz.net/forum/questions/71028/productbacklog-results-in-error-quottypeerror-_e-is-undef
But I am unable to find a Invalid Plan View under Plan Views. I do see some plans with the red x next to the promote button on the top of the frame. Most of the plans do not have the red x but some do.

Does anyone have any knowledge on how to fix the broken plan in my scenerio? Thanks.

Comments
Adam Wereszczynski commented Mar 12 '14, 4:11 a.m.

Hi,

Are you inheriting Process Configuration from a master process?
Perhaps the invalid plan view is in the master PA in such case.

One answer



permanent link
Don Yang (7.6k2195131) | answered Mar 12 '14, 1:53 a.m.
For now, we only identify the error you encountered can be workarounded by the procedures specified in the two forums. Please see the technote and make sure you do the exact same check:

http://www-01.ibm.com/support/docview.wss?uid=swg21590775

>>"I do see some plans with the red x next to the promote button on the top of the frame."
can you please provide more info on this with some screenshots?
Also if you put ?debug=true (before # in your URL when accessing to the plan), do you see the same message as in the technote?

Your answer


Register or to post your answer.