It's all about the answers!

Ask a question

Not able to fetch the code - The UUID of the build engine is "default"


Saurabh Jain (558) | asked Feb 11 '14, 11:56 a.m.
edited Feb 19 '14, 2:03 p.m. by Jennifer Cianchetta-Riordan (2512)
Hello ,

I am trying to execute a build from eclipse RTC client, for the same I have create a build engine and a build definition.

And after execution I am getting this message in the warning while executing first step of my BF project whcch is basically fetching of source code from RTC source control.

The build engine is either not in the repository, or it cannot be accessed by the following user: "saujain". The UUID of the build engine is "default".

I crosschecked my engine exists in the repository and I have permission of requesting build for my userid - saujain .

Why it is showing the UUID of build engine us default ??
Is it correct ?

Please advice , where I am doing mistake.

Thank You




Accepted answer


permanent link
Spencer Murata (2.3k115870) | answered Feb 12 '14, 8:33 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
 It is likely that you do not have an environment assigned to the project that is getting executed in BF from RTC.  RTC has to synchronize the properties from its build definition to the BF project, so there must be an environment assigned so there is somewhere to save the properties.  The engine getting assigned to Default in this case just means that the real engine value from RTC was never written to BF.  So verify that the property engineUUID exists in an environment assigned to the BF project getting executed from RTC.

~Spencer
Saurabh Jain selected this answer as the correct answer

Comments
Saurabh Jain commented Feb 12 '14, 1:48 p.m.

Hi Spencer,
I have crosschecked i have an environment assigned to my BF project and this environment has the variable engineUUID , with a value default.
In RTC I clicked on synchronize properties button , and after that I saw in RTC properties tab that only few properties are visible there like
Repository_Address, Build_user, Build_Password,Build_Toolkit_Path,ANT_HOME,Build_Engine_PATH , but i am not able to see engineUUID and buidResultUUID .. is it correct ?

Or should these properties(engineUUID and buidResultUUID) will also be visible in RTC ?

Thanks for your time.


Nick Edgar commented Feb 12 '14, 3:15 p.m.
JAZZ DEVELOPER

Or should these properties(engineUUID and buidResultUUID) will also be visible in RTC ? 
Yes, they need to be on the RTC build definition side too. Synchronize Properties should add them.  If not, please add them manually.  Their values can be blank/empty, but they need to be defined in order for the RTC/BF integration to set their values when the build is initiated in BF from RTC.


 


Nick Edgar commented Feb 12 '14, 3:43 p.m.
JAZZ DEVELOPER

Actually, many of the RTC-specific properties are hidden on the build definition, but Synchronize Properties should still add them. You can check by trying to add a property manually, e.g. engineUUID or buildResultUUID. If it has already been added, the add property dialog should warn that there's already a property with that name.


Saurabh Jain commented Feb 12 '14, 7:02 p.m. | edited Feb 12 '14, 7:03 p.m.

Hello Nick ,
I tried that also but i was not aware of what should be the value of engineUUID and buildResultUUID.
But one thing luckily worked in my case , earlier in my environment in BF console values for engineUUID and buildResultUUID was set to "default" , and when i changed these values to empty string "" , it started working fine and it cloned all of my RTC repository code on the BF agent at the location which i mentioned in build definition.

For now I can see this issue is resolved , but this was very weird.

Now I am planning to write 2nd step that will build the projects using Ant copied on the BF agent.

Thanks again for your time.



Nick Edgar commented Feb 13 '14, 9:03 a.m.
JAZZ DEVELOPER

I suspect changing from "default" to empty string was just a coincidence. It might have been failing to propagate the value earlier due to connection problems. On the RTC side, it doesn't care what the value is on the BF env, it just sets the value from RTC.


Saurabh Jain commented Feb 13 '14, 11:03 a.m.

Hi Nick,
I tried other way also and changed the value back to "default" and it started breaking again .
Weird thing that I am not able to understand , when i am synchronizing the properties why it is not showing me the properties in RTC that are already defined in my environment in BF console.

Thank You


Nick Edgar commented Feb 13 '14, 1:04 p.m.
JAZZ DEVELOPER

That's really odd. Is there any corresponding error entry in the RTC server-side ccm.log?


As for the hidden properties, most of the properties added to the BF environment correspond to built-in attributes of the build/engine, or to properties that are provided in other pages in the RTC build definition, e.g. the SCM settings, so there's no need to make them visible in the Properties page.  Other properties in the BF environment that are not 'special' should show as regular properties in RTC.  I can appreciate that the hidden properties can be confusing, though. We might reconsider of the non-SCM ones.


Saurabh Jain commented Feb 13 '14, 5:19 p.m.

I checked in the RTC server logs , but there is no such error.

But right now I am facing one more weird issue, when it is copying the code from RTC to a location on BF agent , it is not bringing .java files. When i checked the java packages on the location they are empty.

Other files like
.jsp , .js ,.css *.jar has been copied successfully ,its only java files that are not copying.

Do u have any clue why it is happening ? :(

Thank you


Nick Edgar commented Feb 13 '14, 5:46 p.m. | edited Feb 13 '14, 5:46 p.m.
JAZZ DEVELOPER

Try doing Show Repository Files on the component in the stream, as well as in the build workspace (the repository workspace, not the loaded sandbox). Do the .java files show there? Do you have any load rules configured in the build definition that might be excluding files? Could there be a script running after the load that's deleting .java files?


Saurabh Jain commented Feb 14 '14, 10:36 a.m.

1.) doing Show Repository Files on the component in the stream ?
Ans : Yeah , it is showing me all the java files.
2.) Do you have any load rules configured in the build definition that might be excluding files?
Ans : I didn't configure any rules as such , that can exclude *.java files.
3.) Could there be a script running after the load that's deleting .java files?
Ans : I don't think so we have any script like this.

4.) as well as in the build workspace (the repository workspace, not the loaded sandbox).
Ans : Yes , i checked there in my build workspace files are there.

Any other clue that can help me.


Nick Edgar commented Feb 14 '14, 12:27 p.m.
JAZZ DEVELOPER

Can you try loading the build workspace into your RTC Eclipse client?  Do the .java files come through then?


Saurabh Jain commented Feb 14 '14, 1:28 p.m.

I am not sure i correctly understood "loading the build workspace into your RTC Eclipse client" .

Let me explain what i tried .
1.) Under "My Repoistory Workspaces" , i right clicked on my workspace and opened it.
2.) Once it is opened , i clicked on "Show Repoistory Files" button , and there I am able to see java files.

I tried for personal build , but same result.
Interesting thing is it is generating the correct package structure , but those packages don't have any file in it.


Saurabh Jain commented Feb 14 '14, 3:39 p.m.

1 thing that i noticed just now , it is copying some of the files and skipping others.


Nick Edgar commented Feb 14 '14, 4:29 p.m.
JAZZ DEVELOPER

Any errors in the step log for the first BF step (the one running JBE)?



Saurabh Jain commented Feb 14 '14, 4:52 p.m.

these are the last few lines of BF step log ... i think either its a timeout issue or Warning
Please suggest.

274    2/14/14 4:28 PM        WARNING    Status WARNING: com.ibm.team.filesystem.client code=0 Problem detected: your filesystem supports symlinks but you are missing the Eclipse native support for them null275    2/14/14 4:33 PM        TMO    Timeout after 300 seconds.276    2/14/14 4:33 PM        RESULT    999277    2/14/14 4:33 PM        INT    CRRBF0878I: Env Group '[ADAPTOR]' variable 'Last_Run' set to [].278    2/14/14 4:33 PM        INT    Finished Block Processing.279    2/14/14 4:33 PM        MJC    CRRBF1576I: Call JazzJBE adapter and fetch source code completed (0)







Nick Edgar commented Feb 14 '14, 4:57 p.m.
JAZZ DEVELOPER

Ah, it looks like the SCM step is timing out after 5 mins. This can be adjusted on the step in BF.  Is the workspace large?  Is it expected that it would take >5 mins to do the accept/fetch? 


Saurabh Jain commented Feb 14 '14, 5:05 p.m. | edited Feb 14 '14, 5:05 p.m.

Yeah repository contains lot of projects and I am expecting it will take more that 10 mins.

So, to achieve this I increased the time out to 20 mins in "fetch step" of my project , but somehow it is not picking the new value i.e 20 . It is still failing at 300 secs.

Any clue ??


Saurabh Jain commented Feb 14 '14, 5:47 p.m.

Update :
I created a new property in my environment "__TIMEOUT " and set it for (1800 secs) 30 mins.
Now after this my step is not getting timed out , it is something else that is getting timed out at 360 secs. I am not sure what it is either BF agent or JBE Adapater or anything else .
On forum also I didn't find anything related to it.
Here is the log.

277 2/14/14 5:03 PM EXEC Feb 14, 2014 5:18:00 PM com.ibm.team.filesystem.client.internal.LoggingHelper log 278 2/14/14 5:03 PM WARNING Status WARNING: com.ibm.team.filesystem.client code=0 Problem detected: your filesystem supports symlinks but you are missing the Eclipse native support for them null 279 2/14/14 5:09 PM ERROR An exception was thrown by the step provider runtime. 280 2/14/14 5:09 PM ERROR CRRBF0218I: Timeout after 360 seconds.
Please suggest what to change now.


Nick Edgar commented Feb 16 '14, 2:53 p.m.
JAZZ DEVELOPER

I'm not aware about what a "__TIMEOUT" env vars does.  The error shown indicates that the step in BF still has a low timeout (360 secs = 6 mins, which is different than the default of 5 mins).  Try:

- navigate to project in Build Forge
- click the step that runs the SCM phase (first step usually)
- check its setting for 'Timeout in minutes'
- try changing this to something large like 30 mins


Saurabh Jain commented Feb 17 '14, 12:21 p.m.

Nick ,
I crosschecked it again , the timeout in the step is 30 mins and when I ran it again , it failed with the same the error message after 360 secs.
And about the _TIMEOUT , i found it on one of the post , link for that is here.
https://jazz.net/forum/questions/76597/build-agent-tmo-timeout-after-300-seconds

But right now I stucked at this error.
ERROR CRRBF0218I: Timeout after 360 seconds.


Spencer Murata commented Feb 18 '14, 8:17 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

360 is the default timeout for the Eclipse client.  Try adding a: 

-vmargs -Dcom.ibm.team.repository.common.transport.                   TeamServerConfiguration.socketTimeout=900000 
to the end of the JBE execution in the adaptor script.  The _TIMEOUT is a BFA value that overrides the BFA default timeout value, but BFA is not reporting the time out here.

~Spencer


Saurabh Jain commented Feb 18 '14, 10:33 a.m.

Spencer ,

I have added the suggested argument at the end of JBE fetch step , but still I am getting the same error. Here , how my JBE script look like.
Have i added it correctly ?

.source JazzJBE 
-vmargs -Dcom.ibm.team.repository.common.transport.TeamServerConfiguration.socketTimeout=900000



Nick Edgar commented Feb 18 '14, 11:04 a.m.
JAZZ DEVELOPER

I don't think it's the JBE requests timing out. The default timeout there is 480 seconds (8 minutes), and the error would be different if that was the case.

The error:
> ERROR CRRBF0218I: Timeout after 360 seconds. 
Is clearly from Build Forge.

Spencer, is there some global timeout setting that needs to be changed?


Nick Edgar commented Feb 18 '14, 11:07 a.m. | edited Feb 18 '14, 11:07 a.m.
JAZZ DEVELOPER

also the -vmargs -D… would have to go in the adapter, not added to the BF step. But as I said in the last comment, I don't think that's the issue, so I'd leave TeamServerConfiguration.socketTimeout as the default for now.  Note that this timeout is for individual requests, not the overall runtime of JBE or the SCM accept/fetch.



Saurabh Jain commented Feb 18 '14, 12:53 p.m. | edited Feb 18 '14, 12:54 p.m.

As this question is going out of context from the original question.
So, I have created a new question here.

https://jazz.net/forum/questions/142631/warning-crrbf0218i-timeout-after-360-seconds

Please respond there.

showing 5 of 25 show 20 more comments

Your answer


Register or to post your answer.