It's all about the answers!

Ask a question

Client server mismatch using the RTC Plugin with Jazz/CCM server in IBM RAD


Michael Plautz (26711) | asked Aug 21 '14, 3:01 p.m.
edited Aug 21 '14, 3:07 p.m. by Stephanie Taylor (24115)
 I have IBM Rational Application Developer for WebSphere (or RAD) version 7.5.4 installed, and I have the June 2nd 2014 release of Jazz, version 5.0, installed on a server.  I went to the downloads page to download the IBM Installation Manager repository for the Eclipse RTC plugin for this version.  I initially (without knowing better) downloaded the Client for Eclipse 4.2.x IBM/IM repository and installed it into RAD, and (after removing the requirement for SSL on my server) tried to Create a Repository Connection, and got the following error:

Client/server version mismatch logging into 'hostname.server.com'.
CRJAZ1176I There is a version mismatch for the "com.ibm.team.repository.common.internal.IRepositoryRemoteService" service.  The server version is "7" while the client version is "6". Both client and server version must match. Check the overall version of the client using Help->About and ensure it is compatible with server version "5.0" and build id "RJF-I20140509-1319".

So, thinking that perhaps I had installed the wrong version, I used IBM Installation Manager to uninstall this feature.  Peculiarly enough, I still saw it existing in RAD (as in, I still saw the Jazz Administration perspective, etc.) after uninstalling it.  Well, I instead installed the Client for Eclipse 3.6.x using IBM/IM, and I am still getting the same error.

On a side note, I went to the same download page and used the Eclipse p2 repository to install the RTC client into normal Eclipse (not RAD), and it works just fine.  From the same page.  So,

1. Did IBM Installation Manager actually uninstall the first version from RAD?
2. If none of these are working on RAD, what am I doing wrong?  How do I remedy this?

Accepted answer


permanent link
Rosa Naranjo (2.8k11420) | answered Aug 21 '14, 3:53 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
edited Aug 21 '14, 3:59 p.m.
Michael,
UPDATE: According to the CLM System requirements for 5.0, only RAD v8.5 or 9 is supported, not 7.5.4.

I am not sure how to help you with your specific questions. However, I believe what you should have used to install RTC into RAD is the Eclipse p2 repository you later tried with normal eclipse.
But, I also noticed that in this topic of the 5.0 infocenter, it mentions that Installation Manager gives you the option to install into an existing Eclipse. Is that what you selected? 
If you want to install the client into an existing Eclipse workbench, select the Extend an existing Eclipse check box and provide the location of the Eclipse IDE. When you extend Eclipse, the package functions are available in your Eclipse IDE, but the package files are installed in their own directory.

Also, the message you received has nothing to do with the rest of the issues. It has to do with what client you tried to use to connect to a 5.0  server. If doesn't sound like you were using the right version of the client.  A 4.0.x RTC Eclipse client ot a 5.0 Eclipse client can connect to a 5.0 server.  For example, I am running RTC 4.0.6 eclipse client and I can connect to the RTC repository on Jazz.net which is currently running a 5.0.1 milestone build. 

Without looking at IM logs, it is really hard to unravel this problem. You may want to contact customer support so they can collect logs from your system if you are stuck and cannot figure out what is currently running in your RAD 7.5.4.
Michael Plautz selected this answer as the correct answer

Comments
Rosa Naranjo commented Aug 21 '14, 4:02 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

Another link regarding shell sharing and RAD + RTC version compatibility
http://www-01.ibm.com/support/docview.wss?uid=swg21279139


Michael Plautz commented Aug 21 '14, 4:17 p.m.

 Thanks for the very quick response, Rosa.

  • I downloaded both of these files from the very same page, and I included a link to it in my question.  One of the files I downloaded was the Eclipse p2 repository, which worked for installing this plugin into Eclipse.  The other one I downloaded (from this same 5.0 downloads page) is called RTC-Eclipse-Client-repo-5.0.zip.  This was listed as an Installation Manager repository.  If I understand correctly, the p2 repository is strictly for the Eclipse software updater/installer, and the latter is strictly for IBM Installation Manager, and they cannot be mixed.
  • I did not check this.  When I do, I get an error (Message ID CRIMA1166E) saying that there is already an installation package installed.
  • Since both downloads came from the same page, the p2 repo and the IBM/IM repo, I am not sure if the version is the problem.  I am worried that first version was never actually uninstalled.
I will call support


Michael Plautz commented Aug 25 '14, 9:43 a.m.

 Rosa, thanks again for the link.  I had a colleague on a different team who has RAD 8.5 successfully install this the eclipse RTC plugin for eclipse version 3.6.x, and he also successfully connected to the Jazz server, much like I was able to in a normal eclipse environment.  I mistakenly jumped the gun and used IBM Installation Manager to install the 4.2.x repo, and I am sure that is causing some problems.  I took a look at your link, and it doesn't even look like RAD 7.5.4 is Eclipse 3.6 (it appears to be older than that).


The problem I now have is how do I uninstall this incorrect RTC plugin.  When I go to IBM Installation Manager and uninstall it, it still appears as being installed in my RAD, despite going through the uninstallation process.  I may just have to 1) completely uninstall and reinstall RAD, or 2) get rid of RAD 7.5.4 and go with a more recent version (despite my teams hesitance to move forward :).

Your answer


Register or to post your answer.