It's all about the answers!

Ask a question

WARNING: CRRBF0218I: Timeout after 360 seconds.


Saurabh Jain (558) | asked Feb 18 '14, 12:52 p.m.
edited Feb 19 '14, 2:05 p.m. by Jennifer Cianchetta-Riordan (2512)
I am getting the above mentioned warning message while executing the JBE step , in this step I am trying to fetch the code from RTC repository and copying it on the BF agent.

Here , is the complete log from Build Forge server.
WARNING: CRRBF0218I: Timeout after 360 seconds.Feb 18, 2014 10:14:31 AM com.ibm.jas.mjc.step.SimpleStepProviderFiberAction reportExceptionSEVERE: Exception during StepProvider runtimecom.ibm.jas.mjc.api.model.MJCException: CRRBF0218I: Timeout after 360 seconds.        at com.ibm.jas.mjc.model.ResultImpl.checkTimeout(ResultImpl.java:129)        at com.ibm.jas.mjc.step.SimpleStepProviderFiberAction.executeStepProvider(SimpleStepProviderFiberAction.java:175)        at com.ibm.jas.mjc.step.SimpleStepProviderFiberAction.action(SimpleStepProviderFiberAction.java:139)        at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:202)        at com.ibm.jas.mjc.step.SelectingStepProviderFiberAction.action(SelectingStepProviderFiberAction.java:139)        at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:202)        at com.ibm.jas.fiber.action.flow.Block.action(Block.java:100)        at com.ibm.jas.fiber.FiberAction.call(FiberAction.java:202)        at com.ibm.jas.fiber.Fiber.runFiber(Fiber.java:786)        at com.ibm.jas.fiber.FiberThread.runFibers(FiberThread.java:264)        at com.ibm.jas.fiber.FiberThread.run(FiberThread.java:251)        at com.ibm.jas.mjc.ProcessThread.run(ProcessThread.java:88)Feb 18, 2014 10:14:31 AM com.ibm.jas.mjc.ProcessThread$ProcessThreadExceptionHandler uncaughtExceptionSEVERE: Exception during Job (34e9c12d0c671000b2066dbadd56f071) execution, marking Job as failure...
Note : I have already tried with setting timeout at step level , but it is not working in my case.

Any help or suggestion is really appreciated.




















Comments
Nick Edgar commented Feb 18 '14, 1:46 p.m.
JAZZ DEVELOPER

Hi Saurabh, this is definitely on the BF side.  I'm out of ideas for what to suggest. Please file a work item against BF, including a screen shot of your step settings, and we'll proceed from there.  Another option is to open a ticket with Support.


1
Nick Edgar commented Feb 18 '14, 1:47 p.m. | edited Feb 19 '14, 2:24 p.m.
JAZZ DEVELOPER

This looks like the same issue being discussed in https://jazz.net/forum/questions/141835/not-able-to-fetch-the-code-the-uuid-of-the-build-engine-is-default


Saurabh Jain commented Feb 18 '14, 2:07 p.m.

Can you please tell me how to file a work item against BF ?
It would be great if you can refer some link


Nick Edgar commented Feb 18 '14, 2:50 p.m.
JAZZ DEVELOPER

You can use the 'Submit a bug' link off of the BF product page:



Saurabh Jain commented Feb 18 '14, 3:15 p.m.

Accepted answer


permanent link
Nick Edgar (6.5k711) | answered Feb 19 '14, 2:29 p.m.
JAZZ DEVELOPER
edited Feb 19 '14, 2:30 p.m.
In email you pointed out that the JazzJBE.xml adaptor has:
<run command="runJBE" params="" server="$BFServer" dir="/$BF_PROJECTNAME_PHYS/$BF_TAG" timeout="360"/>

The timeout there is most likely the culprit.  My apologies, I forgot that the adaptor had it's own timeout (and this is a required attribute).  Try creating a new adapter based on the JazzJBE adapter template, in: Build Forge console > Projects > Adaptors.  Call it 'JazzJBE-mod'.  Don't forget to set its access group as appropriate.
Then, change the timeout from 360 to something larger, like 7200 (2 hours).
Then in your build step using the adapter, change it from .source JazzJBE to .source JazzJBE-mod



Saurabh Jain selected this answer as the correct answer

Comments
Saurabh Jain commented Feb 19 '14, 3:01 p.m.

Thank you very much Nick.

It worked now and didn't fail this time in copying the code because of timeout.

I have a question here ,
When I am changing timeout value in the existing adapter JazzJBE.xml from 360 to 7200 , why it is not working , but in case of new adapter it is working?

Thanks again for your time.


Nick Edgar commented Feb 19 '14, 3:20 p.m.
JAZZ DEVELOPER

I'm not exactly sure why modifying the original adaptor did not work.  I think you need to get BF to update the adaptor templates from disk.  Searching just now, I see you need to do: Administration > System, choose Reset Adaptor Templates, change value to Yes, save.  


Saurabh Jain commented Feb 20 '14, 1:15 p.m.

Yes Nick , you are correct by Reseting Adaptor Templates it picked up the modified template.

Your answer


Register or to post your answer.