It's all about the answers!

Ask a question

Create Sample failed at "creating artifacts"


Karen Steele (1.1k1127102) | asked Feb 07 '14, 7:09 a.m.
 The create CLM sample JKE Banking created the project areas and lifecycle connectivity, but failed at the creation of the artifacts in those respective project areas.  Is there a way to manually run those scripts and populate the date into CCM, RQM and RRC ?  

2 answers



permanent link
Ralph Schoon (56.4k23642) | answered Feb 07 '14, 7:32 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Karen, if it fails, this is usually due to missing licenses for the user you run. you need Developer and professional Licenses for all the tools you include.

Rename and archive the failed projects and create the sample again with the required licenses. There is no way to generate the artifacts from scripts. This is built in. If it keeps failing, check the app that fails, your setup might be broken.

permanent link
Steve Arnold (28121411) | answered Feb 07 '14, 7:34 a.m.
Are there any clues as to why it failed in the log files ( install home/server/logs and sometimes in server/tomcat/logs )?  You may have to fix whatever it is ( perhaps running out of memory ?)

You can try and recreate with the sample with a different name - and then archive the projects which have failed.  Thats normally the best way.  I'm not aware of any other way to create the sample.

Comments
Karen Steele commented Feb 07 '14, 7:52 a.m.

Yeah - I got a java out of memory ... so what I've done is exactly the same as you've suggested, restarted the server, and then archived the elements in question and re-created the samples individual and re-connected.  Seems to be the only way around it for me ...

My servers are rather old and just for building / experimenting with the newer versions.

Your answer


Register or to post your answer.