It's all about the answers!

Ask a question

How can you change a project dashboard that no longer allows you to add or remove widgets due to errors?


James Anderson (4611) | asked Jan 27 '14, 9:22 a.m.
edited Jan 27 '14, 10:02 a.m. by Krzysztof Kaźmierczyk (7.4k34997)

We have one project in RTC with 2 project dashboards, and we can no longer modify either project dashboard or add another dashboard.  We can still modify personal dashboards and project dashboards for other projects.  But, if we try to update this particular project's dashboard, the widget will go on and say "Loading...", but never proceeds past that.  Then, if a save is attempted, this error is reported.  Any idea how to get past it?

There was a problem saving the dashboard: HTTP/1.1 400 Bad Request

hide details

Invalid content: Invalid RDF:
{W104} Unqualified property elements are not allowed. Treated as a relative URI.
{W136} Relative URIs are not permitted in RDF: specifically
{W104} Unqualified property elements are not allowed. Treated as a relative URI.
{W136} Relative URIs are not permitted in RDF: specifically
Unable to load /ccm/proxy?uri=https%3A%2F%2Fjazz.cs.myharris.net%3A9443%2Fjts%2Fdashboards%2F16%3FcontentType%3Dapplication%252Frdf%2525xml status: 400

Comments
Krzysztof Kaźmierczyk commented Jan 27 '14, 10:01 a.m.

Hi James,
I have never seens such issue before. Therefore could you please provide more information for us:
1. What is your RTC server version?
2. Please provide error message and stack trace appearing in the log when you are opening dashboard
3. When did the issue appear first time?


James Anderson commented Jan 27 '14, 11:25 a.m.

The RTC server version is 4.0.5.  There is no error on the dashboard or any logs under RTC\server\logs on the server when loading or opening the project dashboard.  The existing project dashboards work fine, but they cannot be modified.  I tried restarting the JTS and that didn't help.  I was first made aware of this issue last week, but some on the team report that it has been that way at least since upgrading to 4.0.5 in December.  None of the other project's have the same issue with their dashboard.


Krzysztof Kaźmierczyk commented Jan 28 '14, 5:03 a.m.

Hi James,
In that case we might get additional information using Firebug session. Can you start your Firebug and provide errors from Firebug console when you reproduce the issue and also output from net->xhr tab (what queries finished with result different than 200).

If you don't feel comfortable with Firebug, I would suggest you opening new PMR.

Accepted answer


permanent link
James Anderson (4611) | answered Jan 29 '14, 8:38 a.m.
After switching from Internet Explorer to Firefox to use Firebug, I discovered this was an Internet Explorer problem only.  The dashboard exhibits normal behavior in Firefox, but continues to not work in IE 8.  It may work in newer versions of IE.
Millard Ellingsworth selected this answer as the correct answer

Comments
1
Millard Ellingsworth commented Jan 29 '14, 11:32 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Since IE8 is still on the supported browsers list for CLM 4.0.5, you are certainly welcome to file a defect (or PMR/APAR) to have this addressed if you require this support.


James Anderson commented Jan 29 '14, 11:34 a.m.

It was through a PMR that I discovered the workaround to this problem.

Your answer


Register or to post your answer.