It's all about the answers!

Ask a question

Need help with Group Filters: Acting like wildcards


Ginny Ghezzo (33311117) | asked Aug 29 '13, 6:12 p.m.
JAZZ DEVELOPER
I am using group filters in a query widget.  They work great until I get to including a string that is common with most of the other string.  When I add that, it acts like a wildcard instead of a string comparison and groups everything else under it.  

Example :
Create a query that lists work items with a tag and a foundIn value of the various 4.0 milestones and candidates.
Create two group filters
FourPointOhThree 4.0.3|4.0.3 M3
FourPointOh 4.0 RC5|4.0 RC1|4.0 RC3|4.0 M8|4.0 RC0|4.0.0.1|4.0

Results: Everything that does not have a value of 4.0.3 or 4.0.3 M3 gets put in the FourPointOh group.   If I take the 4.0 off the end of the filter lists, then I get the expected results EXCEPT the 4.0 are on their own.  
To work around it I created two more groups (FourPointOhTwo and FourPointOhOne) however, this is not a great solution because if other 4.0.x are there they are going to get folded into the FourPointOh group.

Is this a bug?  Is there some crazy syntax that is not described here https://jazz.net/downloads/rational-team-concert/releases/2.0.0.1?p=news ?  

Comments
sam detweiler commented Aug 30 '13, 7:24 a.m.

sorry. I don't see the problem.

>Everything that does not have a value of 4.0.3 or 4.0.3 M3 gets put in the FourPointOh group

where else were they supposed to go? you only made two groups.. so everything has to fit into that model.  you list everything specifically.

what if you had one catch all group..  (last is the 'not one of the other specific groups, but still a 4.0 based)

FourPointOhThree 4.0.3|4.0.3 M3
FourPointOhx 4.0 RC5|4.0 RC1|4.0 RC3|4.0 M8|4.0 RC0|4.0.0.1
FourPointOh 4.0   


Ginny Ghezzo commented Aug 30 '13, 7:53 a.m.
JAZZ DEVELOPER

Sam,
Sorry I did not clarify.  I want to let some things, especially unexpected things, to fall out of groups.   ie if it is not in the list then I don't want it in these groups

Right now 4.0.4, 4.0.2, etc  were getting rolled into 4.0.   But putting a $ they no longer did.

Thanks,
ginny


1
sam detweiler commented Aug 30 '13, 7:57 a.m.

got it.. Looks like Shubjit's approach means the group filter is using some form of regular expression ($ means 'at the end', ^ means at the beginning)

Accepted answer


permanent link
Shubjit Naik (1.5k1613) | answered Aug 30 '13, 7:13 a.m.
 Hi Ginny

I was randomly trying different options and one of them seems to works.
Not sure if this is the right value, but you could try with ending the filter string with "$"

Example : FourPointOh 4.0 RC5|4.0 RC1|4.0 RC3|4.0 M8|4.0 RC0|4.0.0.1|4.0$

Let me know if this works for you

Ginny Ghezzo selected this answer as the correct answer

Comments
1
Ginny Ghezzo commented Aug 30 '13, 7:51 a.m.
JAZZ DEVELOPER

I am thrilled Shubjit!   This is is perfect .  What was your approach to trying different options?   Did you find any other cool characters that make group filters fun and useful? 

Thanks again!!!
Ginny


Shubjit Naik commented Aug 30 '13, 7:55 a.m.

Great that this worked for you too :)

I was trying the switches that I remember for Wild Cards, \, &, *, $ and "$" worked.
Might be a hidden feature.

Found that, if we use any other character, it ignores the entire filter string.

Your answer


Register or to post your answer.