It's all about the answers!

Ask a question

RTC plan views: Why are archived iterations still visible in plan view?


Markus Giacomuzzi (4549) | asked Jan 05 '14, 1:19 p.m.
edited Jan 05 '14, 1:22 p.m.
Why are archived iterations still visible in plan view? I would expect they were hidden and only not archived ones shown.
Alternatively there could be a plan attribute to choose if an archived iteration should be shown or not.
However, by default an archived iteration should not be shown anymore.

Just updated from 4.0.3 to 4.0.5
a plan showing archived iterations

2 answers



permanent link
Isabel Murakami (3811413) | answered Jan 06 '14, 6:27 a.m.
Hello Markus,

Use the "Show Archived" button in the project area editor (either Web Ui and Eclipse).
(CLM 4.0.4 used for the screen shots below)

Show archived

Sprint archived is not showed more







Release Plan view does not show more the archived "Sprint 1" :

Release Plan View




Comments
Guido Schneider commented Jan 06 '14, 10:30 a.m.

In our case they still are visible, but get the word "(archived)" automatically added. Like shown in the picture above from Markus.

In the PA Configuration they are not shwon, if the show archived button is not pressed.


Guido Schneider commented Jan 06 '14, 11:30 a.m.

In one of my PA, the archived Iterations are gone, as soon as I remove the Display=Tree Option in the plan view.

But in others this has no effect and archived Iterations are still shown.. And in JKE Banking this option is set, but the Iteration is correctly not shown.

From my point of view this is a bug.


Jared Burns commented Jan 06 '14, 12:02 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The toggle to Show/Hide Archived in the project area editor only affects the project area editor. It's just a local view option that won't have any effect elsewhere in the system. 


Guido Schneider commented Jan 06 '14, 2:50 p.m. | edited Jan 06 '14, 3:37 p.m.

Hello Jared,
I don't think you are right.

At least in Planning, when you create a new plan, archived iterations are not displayed. And also not, when you set the "Planned For" value for a WI with help of the row menu in a plan.
In the workitem editor, it is not possible to select archived iterations. You canalso not search for them in the Iteration selection popup.

What is missing is a real suppression of archived Iterations in the "Iteration" view of a plan (grouped by Iteration). Specially when there are NO open items in it. We may discuss displaying archived Iterations when there are still open items.


Aradhya K commented Jan 06 '14, 11:53 p.m.
JAZZ DEVELOPER

Hi Jared.

This issue seems to be a valid defect on the planning.
Currently in the release plan we do not hide the Archived Iterations if there are some work items planned for the iterations.


Kevin Ramer commented Oct 08 '14, 11:16 a.m. | edited Oct 08 '14, 11:56 a.m.

There is a "Show Archived" under the Filter menu on the Team Artifacts view.  Maybe that is checked on the eclipse client.  [ and I know this isn't about the hieararchy, just that no one mentioned the filter in the same context ]

showing 5 of 6 show 1 more comments

permanent link
Florian Grannesberger (6) | answered Oct 08 '14, 10:20 a.m.

The same issue we have with the Group by function in a planview. If I "Group by" an Attribute, based on a enumeration list, archived attributes are shown in the planview.  

All WI with such an Attribute assigned are resolved, however, the archived Attribute is shown.

It shouldn't be displayed, at least there should be the possibilityto Show/hide as mentioned above.

So the plaview in this case is not useable for us.

Your answer


Register or to post your answer.