Jazz Team Server shuts down every night.
We have a Dev system setup for our user sandbox. Running on Windows 2008 R2. 4gig vm, OOtB 4.0.4 setup.
runs all day long, no issues.. sometime overnight tomcat shuts down. last thing we see is an out of memory error.
the users are in Europe,. so by the time our dev staff arrives in the US, they have lost most of their day.
we have tried to set this thing up as a windows service, but can't get it to come up.
the doc between 4.0.4 and 4.0.6 seems to have changed.
Is there any update to the doc in 4.0,4, or anyone have any experience here. weird for me.. as all my test systems run all day long every day for months without issue (but I don't use 2008 server), real OS or VM.
2 answers
Hi Sam
I would first try and track down why you are getting out of memory errors before you start trying to set this up as a service. 4 gig for any Windows server seems a little low. Check your server startup settings so that you allocate at most 50% of your actual machine (or virtual machine) memory to the JVM.
However, once you have uncovered and fixed that problem - the service settings need you to be very specific about any configuration info you put in the .conf files. I recall some of the default settings (like logging) use relative paths - not a good idea when you make the CLM/Jazz server a service. This could explain the ssl cert errors (can't find the cert perhaps)?
anthony
I would first try and track down why you are getting out of memory errors before you start trying to set this up as a service. 4 gig for any Windows server seems a little low. Check your server startup settings so that you allocate at most 50% of your actual machine (or virtual machine) memory to the JVM.
However, once you have uncovered and fixed that problem - the service settings need you to be very specific about any configuration info you put in the .conf files. I recall some of the default settings (like logging) use relative paths - not a good idea when you make the CLM/Jazz server a service. This could explain the ssl cert errors (can't find the cert perhaps)?
anthony
I am trying to set Jazz as a windows service and configured the same as per the instructions provided on IBM site
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Fm_s_server_installation_start_tomcat.html
I am getting below error. I have log4j.properties file present in the /jazzinstallation/server/conf/rm/ but still it it complaining about missing file.
RRC [Start Level Event Dispatcher] ERROR bm.rdm.fronting.server.bootstrap.RRSAppInitializer - CRRRS9750E The log4j.properties configuration file cannot be found for this context: rm.
Any suggestions?
Comments
Rosa Naranjo
FORUM MODERATOR / JAZZ DEVELOPER Dec 17 '13, 5:28 p.m.sam detweiler
Dec 17 '13, 5:48 p.m.